0

I use ConnectBot sometimes to connect to my ubuntu machine, and that works fine, however it just comes up with a standard shell, not my byobu screens that I get when I connect to it using another machine running ssh, such as my windows machine running PuTTy.

This is what I see when I connect using ConnectBot (yes, I use the dvorak keyboard layout):

phone ConnectBot screenshot
phone ConnectBot screenshot (click for larger variant)

And this is what I see when I connect using PuTTy:

PuTTy screenshot
PuTTy screenshot (click for larger variant)

Is there any way that I can see my byobu screens from ConnectBot?

  • What are "Byobo screens"? Mind to include a link? – Izzy Jan 12 '14 at 8:44
  • @Izzy Byobu is a frontend for Screen so I can have multiple shell windows open and they will remain active even when nobody is connected to the machine. When I reconnect to the machine, the windows will still be there from last time. I have added screenshots to the question. – localhost Jan 12 '14 at 11:01
  • Thanks, that makes things clearer :) I've resized your images to better fit. Unfortunately, I must leave the answer to someone else, as I'm not using Screen and so don't know. Good luck! – Izzy Jan 12 '14 at 12:04
  • THere has to be a shortcut for CTRL, just search for it in the ConnectBot settings or help manual. And onece you find it, just use this guide to use screen: help.ubuntu.com/community/Screen (witch has to be installed on your ubuntu machine) – Mihai Jan 12 '14 at 12:10
  • I know how to press CTRL from ConnectBot, the problem is that it doesn't even come up with the byobu screens, it just jumps straight into the blank command line shown in the screenshot when you log in. Is there a way to manually connect to the byobu session? – localhost Jan 12 '14 at 12:17
1

user2183694 suggested that I run byobu attach-session, but when I did that, the byobu screen would come up for a split-second then quickly pop-up at the bottom the message:

cannot exec 'attach session': no such file or directory

Then it would drop back to the normal terminal.

This at least gave me hope that it could work on the phone.

Then I tried just byobu, which gave me the error:

ERROR: Sessions should be nested with care. Remove 'screen' from $TERM to force.

echo $TERM responds with:

screen

But even using TERM= byobu responds with:

Please set a terminal type.

So I tried screen -r, which gave me the self-contradictory message:

There is a screen on:
         3658.byobu      (12/01/14 21:03:57)     (Attached)
There is no screen to be resumed.

But I discovered that screen -r -d works! Unfortunately the -d detaches any other screen connections (eg from my other pc), but at least it works.

I don't know why I have to detach other sessions, I can actually reconnect them from another pc after connecting from the phone without problems though. If anyone knows how to do it without detaching existing sessions, that would be good.

TLDR use screen -r -d

Edit: I also asked this question on the AskUbuntu site, as the machine I'm connecting to is running Ubuntu, and this answer is relevant.

So, the best answer is: If you go into ConnectBot's "Emulation Mode" settings and change it to "xterm" or "xterm-256color", byobu will work properly from the phone.

|improve this answer|||||
0

You should be able to use the attach-session command to attach your existing byobu session.

byobu attach-session
|improve this answer|||||
  • Didn't work, but see my answer for what did work. Thanks for heading me in the correct direction! – localhost Mar 22 '14 at 4:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.