From one day to the next, TalkBack started to tell me on which home screen I am. It is always using the Google voice, even if I set it to Samsung TTS.


  • Page 2 of 5. (German pronunciation)
  • Der Ordner ist geöffnet.
  • Der Ordner ist geschlossen.

(My locale is German)

TalkBack was switched of before and when I go to settings, the text entry of TalkBack reads "off". When I enter into the TalkBack settings however the slider is switched to "on". Switching it of does not help as it always stays on but displaying off in the textual list view.

My next try was deactivating the TalkBack app completely. This did not solve the problem either.

Is there a setting I do not know about or another trick I could try?

  • wiping the cache partition did not help either.
    – Simon
    Jan 20, 2014 at 8:34

11 Answers 11


Problem can also be caused by airDroid. Go to settings accessibility and ensure AirDroid notifications are turned off. It took nearly 2 hours to find this one as I had done everything suggested in this thread. Frozen screens just remember to use 2 fingers

  • I do not own this phony any more, but yes, I had AirDroid installed at the time. Easily possible that this was the same cause.
    – Simon
    Sep 16, 2015 at 11:44
  • Very good hint.. For me, it was the "Optical Reader" when given accessibility access, whereas Airdroid was well-behaving for a change. Jan 5, 2017 at 12:31

go to application manager and find the google text speech and disable it .


Go to application manager then to All down to Google text to speech and clear data and back out. This worked for my Samsung 3.


I just encountered this problem - I seem to have solved it by doing force stop on the app 'Google Text-to-speech'. (I also cleared application data, but I guess it's the stop that worked.)


LOL, wooow. One really irritating feature if you aren't visually challenged.

My toughest challenge was switching this talkback feature off again for I couldn't scroll down my screen. I would only manage to get the first few options which appeared on the first display of the screen and could see nothing lower down.

To overcome this, try to double swipe instead of single swipe your finger on your screen.

To solve the problem. Just go to your setting, my device, accessibility, then talk back and then disable it from there.

Once you can navigate by double swiping, it's pretty straight forward. Good luck.


A bit late I know, but I've just been having a similar problem with a Samsung Galaxy S3 Mini.

This is how I got rid of it. I tried other ways, but found that if I turned the phone on and off again, the speech would come alive again. This was the only way I could kill it off for good.

Go to Settings -> Accessibility -> Text to Speech and there will be a list of current text to speech providers (I had 2, Google and Samsung)

Go to Application Manager -> All Find Google Text to Speech and disable it If there is no disable button, you will have to click Uninstall All Updates first, then go back, and the button should now read Disable You'll want to do the above step for each Text to Speech option you had in your list. I had 2, so I did it again for Samsung TTS.

Now if you go back to Settings -> Accessibility -> Text to Speech there should be nothing left in the list and your home screen will finally be silent. Hooray!

I also have driving mode and TalkBack disabled. I already had them turned off, but they didn't help.

Hope this helps.

  • Hmm. Though that might work: wouldn't that disable all other TTS events as well? My alarm clock would no longer be able to talk to me in the morning (informing me about weather conditions and calendar events), eBook readers couldn't read books to your ears, and your "car mode" would stop reading incoming SMS while you're driving. Somehow that sounds like killing a fly with a cannon ball (if atomics are unavailable).
    – Izzy
    Apr 29, 2015 at 15:44

Disabling "Samsung TTS" app and also Google text to speech.

  • although this one liner post may solve the issue, but it is always better to write your answer with more details, explaining the step-by-step procedure. May 5, 2016 at 5:34
  1. Open Settings
  2. Go to Application manager
  3. Scroll left to All
  4. Scroll down to Samsung TTS and click it
  5. Click disable and force stop

What is working for me is to have disabled AVG Antivirus. Settings-->Accessibility-->Services-->Antivirus: Disabled


I tried all of these options; disabled everything and the voice kept turning back on. Eventually I uninstalled the cleaning app - AIO Cleaner - and the voice stopped.


Disabling "Google Text to Speech" worked to kill it for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .