3

(Update 2016-01-09: I got rid of the phone after it auto-upgraded to Android 5, so I don't have this issue anymore.)


I keep getting this message every 10 minutes or so on my Samsung Galaxy S3 (non-rooted Android 4.1.2):

screenshot

How can I ignore it?

I want to skip this update as the penultimate one introduced some nasty bugs.

EDIT: Apparently I cannot kill the AT&T service:

screenshot

Also, I restarted the device and the AT&T service is launched at startup.

So I tried to remove the AT&T service from the startup using Startup Cleaner 2.0, but the AT&T service still get launched...:

screenshot

  • You are not obliged to follow through and accept the update. Why not just back out of it by using the onscreen-back button or press the home button? – t0mm13b Jan 29 '14 at 23:11
  • 1
    @t0mm13b The dialog box keeps appearing. – Franck Dernoncourt Jan 29 '14 at 23:19
  • 1
    Can you not go into Manage Apps from settings and disable the updater (I'd imagine it would be called Samsung-Updater or similar)? – t0mm13b Jan 29 '14 at 23:55
  • 1
    Not in play settings, no, in System Settings > Apps, under the header ALL, scroll through the list and see if you can pick out a service or an app called similar FWupdateService or similar. Hint: It is not Google something... – t0mm13b Jan 30 '14 at 0:00
  • 1
    one other suggestion, disable wifi temporarily, does the dialog go away? it appears to wait until wifi gets activated? could try blocking the ip address on your wifi network to mitigate the dialog box? – t0mm13b Jan 30 '14 at 2:33
2

I called AT&T, and this is a mandatory update. Other than rooting, there's no way to avoid the message. You can avoid the download by not going onto WiFi. If you install the update, you need to re-enter WiFi passwords EVERY time you reconnect to a WiFi network. Horrible! I'm avoiding this thing even if have to keep hitting the home key when the message pops up.

  • :( Yeah I'm tired to deal with bug introduced by updates too... did the wifi password issue appear in the latest AT&T update (i.e. the one I'm trying to avoid)? – Franck Dernoncourt Jan 30 '14 at 19:47
  • I didn't do the update, but the AT&T guy said that would be a new "feature" of the update. That's one of the reasons I'm not doing it -- in addition to being fine with the version I have and the blogs saying this new thing is full of bugs, as you also say. – user52335 Jan 30 '14 at 20:31
2

So, I know this is old, but for the record...I found a way to block all updates without root. I downloaded a tool called debloater (google it) and blocked: wssyncmldm.apk wssyncmlnps.apk LocalFOTA.apk

Now it stopped trying to download the update that would always make my back soft key not work. Done and done, and no root required.

1

I just wrestled with this on my galaxy note 9.0. In /system/app there is a file called (for me) FWUpgrade.apk Even though I am rooted it refused to rename or remove it in a file explorer... I tried a few. I eventually just used terminal to chmod 666 it after su-ing to get root. Then I removed it no prob. So, at the term prompt:

su
cd /system/app
chmod 666 FWUpgrade.apk
rm FWUpgrade.apk

Theres a FWUpgrade.odex too, so I rm'd it too. dont know if it worked cause of the chmod or because I was root and I could figure out how to give su permissions to the file explorers I tried. One told me no, the other told me it it worked, but it lied. Hope this helps!

  • Hey, thanks for editing the command line commands for me, I was having some trouble with that! However, I don't think rm'd should be changed to removed, as I was referring to the actual command "rm". Which does happen to be remove, and since it still says "rm FWUpgrade.apk" where it counts, I guess removed work but by that standard it should say, "...just used terminal to change its mode to 666 after super-ing user to root" :) – Ron Kyle Nov 7 '14 at 22:43
  • I find it strange that a chmod on the APK worked. Typically, /system is mounted read-only, requiring a mount -o remount,rw command before changing anything. More than that, in Linux, file permissions don't determine whether or not you can remove a file, directory permissions do. So I would have expected a chmod 777 /system/app rather than anything acting on the APK. – Trebor Rude Nov 25 '14 at 10:10
  • I think you may have something there, although my AT&T upgrade reminder has stopped bothering me since I did this, so idk what to tell you. Perhaps coincedence? I believe that I may have done a mount -o remount, rw command earlier while messing with something else. – Ron Kyle Nov 25 '14 at 10:37
  • That's important information to anyone else coming along, @RonKyle. I just want to get the exact command sequence for posterity. I'll try it on my wife's AT&T S3 when I have the chance. – Trebor Rude Nov 25 '14 at 12:06
  • Yeah I didn't really think of it until your comment... you'll have to forgive me, I'm not super-familiar with Linux just yet... but I do know it wouldnt let me rm the apk until I chmod 666'd it, afterwards it did. I know I didnt change the permissions on the directory, just the file, so...? Also, what did you mean by comal? Command list? Or a typo? :) – Ron Kyle Nov 25 '14 at 12:16
1

I have been using a Note 3 on AT&T for about four months now and I have so far managed to avoid unwanted firmware updates without rooting. I am still running Android 4.3.

I don't want kitkat. It doesn't remember wifi passwords. I have also heard of issues with bluetooth functionality and sd card access limitations. Also, battery life seems to be negatively impacted by these updates. I have dodged the updates two different ways.

One way is by going into the application manager in your settings when you see that annoying update message come up. Select "running" apps in the app manager and you will find "att software update." You can't delete it but you can turn it off or force it to stop. That is a temporary fix. Eventually that message will come back again if you do this.

If you want to block the update for a long time as in maybe a 90% chance of never dealing with it again, there is an app called Ad Blocker. The developer is Smartdog Studio. It disables wifi from being used by whatever apps you want. It's purpose is to block ads from apps that use wifi even though they don't require it to run. If you apply ad block to an app that beeds wifi to run, the app simply will not run at all. But when you go to other apps that you want to use wifi with, your wifi will work with those. This app effectively blocks the software update.

It can be glitchy though. Can turn wifi on and off when you have multiple apps that are capable of completing the same task. Like web browsers for example. If I click on something that is trying to take me to a website, and I have multiple web browsers on my phone, there is a screen that pops up basically prompting me to pick a browser. With ad block on the Note 3, that screen that comes up often turns wifi off. Set defaults to avoid that. And if you have over 300 apps on your phone, and you try to go into ad blocker, it will most likely time out and crash. So if you want it to work well I wouldn't install anymore than about 275 apps on the phone. Otherwise it should be fine.

1

I use nova launcher. Hold finger on screen choose short cuts, activity, scroll down to att update tap on left side. Uou will see the app below it. Click on it it will send it to desktop. When you click on it you can edit The dm connection settings. Click on profile then change to mformation(thats not a typo) Then click on the name choose edit. Then delete all fields except the profile name then save. Try running software update from settings, about device. My device will no longer connect to the dm server. Im saying good by to lollypop! I have screen shots.

  • 1
    It would be better if you add the screenshots. If you can't, then feel free to post it on the comment and let other integrate it to your answer. – Andrew T. Dec 1 '14 at 6:47
1

I haven't tried this, but in your APN settings there's a setting called "fota," which stands for "firmware over the air." Removing that APN type and rebooting your device could stop those updates.

1

After my Galaxy Note 3 got all messed up by Lollipop update, I rooted by phone and installed DisableService app from Play Store.

Using DisableService, you can disable AT&T Software update service.

Good luck.

0

FYI this can be helpful for android owners. I did switch from att to tmobile service after 2 years plan for my galaxys4.The problem I could not get any 4g signal. I was ready to switch back to att free galaxy s5 2 years plan. But I read that the band shift of tmobile and att are different so I found on internet a way to update the ATT shift band to be compatible to Tmobile. For that I need KitKat firmware and I am under lolipop 5.01. I know there is a lot of problems with lolipop(even when I was with att lolipop was terrible, draining battery phone cell signal very weak etc...). So I found away to down grade to kitkat and guess what my 4g is fully functional. it was a firmware problem. So i confirm lolipop is the worst update ever. (lost of 4g, draining battery....) so I am good now with Tmobile. The next step was to root my phone to avoid he update to lolipop.I did use disableservice to kill the ATT update.I Hope this will help for you future next move.

  • How did you down grade to kitkat? (I stopped using my phone after the auto-update to Android 5) – Franck Dernoncourt Dec 11 '15 at 16:31
  • Please focus on answering the asked question (prevent nagging of "AT&T Software update"). Your background/opinion is not relevant and cluttering the answer, making it hard to know what your answer trying to convey. – Andrew T. Dec 14 '15 at 2:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.