0

I am trying to root my Motorola Xoom. Root checker pro currently tells me that "Executing this file can grant root access!" So I want to try that.

the file is located in system/bin and is called su.

I have gotten this far:

adb shell

cd system/bin

How do I execute the system/bin/su file via the adb command line?

  • 1
    have you tried simply to type su, followed by the Enter-key? Sounds pretty stupid, maybe, but that's how su works. No cd'ing, it's even in the $PATH. – Izzy Feb 18 '14 at 22:16
  • I tried that and nothing happened... I'll say adb shell cd system/bin and once it says root@android:/system/bin # I type su and hit enter. then the following line will say "su" and that's about it, i'm back at my previous prompt root@android:/system/bin # ? – olli Feb 18 '14 at 22:35
  • 3
    If the prompt character is a # instead of a $ then the shell already has root access. The root at the start should have been a bit of a clue. – Dan Hulme Feb 18 '14 at 22:38
  • Hm... Root Checker says "Root Access is not properly configured or was not granted". And both apps that I would like to use which require root (basically the only reason why I am trying to root) also don't work, saying I dont have root O_o – olli Feb 18 '14 at 22:44
1

A few suggestions (this is a shell so I'm guessing you have basic shell commands) one or all of these may work:

First try: sh su

Then: bash su

Then: ./su

If it has an extension give all the above commands a try with the extension of su

Also as a suggestion to see what commands are available just type: help

[EDIT]

since you mentioned not having root access try using the sudo command before su (and the above commands if needed)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.