1

I am little confused by the behavior of my device recently. I tried to push a file into my unrooted device and it did throw "Permission denied on me". i did adb root and then tried to push the file and it seemed to be working fine.

Now, when I rebooted the device, I thought that until and unless I do adb root again, I will be seeing permission denied error. But somehow, but my push command was successful this time.

  • Does it mean that root command survives the reboots?
  • If yes, how can I take it back to the state when it was not allowing me to push the files.

I am doing this becuase I am trying to understand the behavior of a device without root access when I automate some commands and unpredictable behavior of my device actually has confused me at this point.

migrated from stackoverflow.com Mar 25 '14 at 20:04

This question came from our site for professional and enthusiast programmers.

  • To which location in the device you tried to push ? – Rilwan Feb 19 '14 at 6:19
  • /data/data/com.android.gallery3d/shared_prefs/com.android.gallery3d_preferences_camera.xml – Lost Feb 19 '14 at 17:28
1

No, ADB root does not survive reboots (thankfully, that would be a nice security hole...) In your case, I'd guess that the permissions on that file got changed, allowing you to push it the second time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.