Similar to this question except my LED light is solid blue.

I've googled the subject but the only thing that came up associated with the blue light was the Facebook app, which I don't even have installed. I can't say I remember ever seeing it before.

The battery was not low. The phone was unresponsive and, though off, the screen felt unusually hot. So I pulled the battery out and let it cool down. The battery's back in but it still won't power on.


I googled "nexus 4 hot", as my phone continues to be very warm (despite remaining, to all other appearances, utterly dead), and ended up on a Google support page, where I was able to chat with a live human being, who emailed me some troubleshooting steps, which were very basic and not at all helpful.

The email included a phone number, 1-855-83-NEXUS, where I talked to another human being, who again wasn't able to help, but was very pleasant.

No one has yet been able to explain the mysterious blue light.

  • I did come across this Android bug report referring to the blue light. After upgrade to KitKat 4.4.2. Is it possible my phone was being upgraded?
    – klenwell
    Aug 8, 2014 at 14:34

1 Answer 1


This post MAY assist you (similar symptoms but no Blue light... worth a try):


Basically it states to try to get your phone into "recovery mode" and then select "Start"... See if this at least wakes up your phone.

It includes a link to this YouTube video with step-by-step instructions:


  • Thanks. That's helpful information. Unfortunately, I wasn't able to get into recovery mode. Phone still unresponsive.
    – klenwell
    Aug 8, 2014 at 2:38
  • Do you have a different power supply you can use (or try)?? Perhaps your battery is not providing enough power to the device :(...
    – Rushnosh
    Aug 8, 2014 at 2:59
  • I don't think battery is the issue. I actually have a a couple batteries (I got one of those extended life ones) and tried them both. Just looked it up and phone is 26 months old. I haven't given up but I'm fearing the worst.
    – klenwell
    Aug 8, 2014 at 3:29
  • GAHH!! No good.. I'd be slumped as well if you have gotten that far. You have tried: * Getting to Recovery but no avial * New battery but no avail One last thing WHICH MAY MAYNOT work, but have everything turned off... Connect your device to the computer (by USB cable)... TRY to turn on your device from there.. and then try connecting to the device via ADB.. (let me know if ADB is new to you)
    – Rushnosh
    Aug 8, 2014 at 4:55
  • adb devices turned up nothing. To be sure I was doing it right, I attached my old HTC Incredible and it was listed.
    – klenwell
    Aug 8, 2014 at 13:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .