1

I've recently upgraded from a Samsung Galaxy S3 (i9300) to a Samsung Galaxy S5 (SM-G900F / klte). The device seemed to be working as desired so I decided to go ahead, root, and install a custom ROM for enhanced functionality and customisation. Root process went smoothly, just running a simple CF-AutoRoot with Odin3 (voids KNOX, but no other problems), then installing PhilZ Advanced CWM Recovery.

From there I decided to install an unofficial build of 4.4.4 CyanogenMod 11. Flashing worked perfectly (and took rather little time!), but upon installation I noticed a strange problem. If I hard reboot (power off, power on) the device, with Wifi & Mobile Data off, the time and date are reset to incorrect values. Usually 01/01/xxxx and the time offset. Same problem occurs even if when I turned off Network-allocated time and and set time manually. I've even tried applications from the Playstore to attempt to sync the hardware clock.

The same problem occurred with other similar CyanogenMod based builds such as [AICP] and [AOSB]. I decided to restore back to the stock ROM and noticed that the clock and date were set correctly on reboot (and also works normally on custom versions of 4.4.2 such as SpeedROMv7).

I checked with the terminal the value of the 'hwclock' (from BusyBox) and it reported an odd date somewhere in 1970, but different to the ones in found on CyanogenMod and other custom roms etc.

Does anyone have any idea what could cause this kind of problem and how to fix such an issue? If anyone wants any additional information about my device, please don't hesitate on commenting in this post. Would be grateful for any feedback. Thanks!

TL;DR - Time/Date resets on hard reboot, (with no internet/data connection). The issue only seems to occur on Android versions > 4.2.2. As stated in detail above, custom 4.2.2 ROMS are fine. The issue persists in all of the 4.4.4 and 5.0.0 builds i've tried.

  • Timezone is correct; it's not a timezone related issue.

*Edit: Problem does not occur with > 4.4.2 ROMs on the Galaxy S3; does anyone have any citation that this could be device-chain related? I would be very grateful if somebody with the same device could test this issue and drop me a line. Thanks.

Alfie.

  • Added information of behaviour on my older device. (Samsung Galaxy S3 i9300). – Alfie J. Palmer Dec 4 '14 at 13:15
0

I conducted serveral months of research and didn't make any considerable progress/findings.

I'd like to report that current-generation 5.0.2 ROMs based on CM-12 appear the have fixed this issue. One can conclude that it was most likely device-chain related.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.