1

I have had an issue for a while with a few of my Android tablets. Those tablets would consistently refuse to install or update software from Google Play.

I have spent days looking for a solution; I have had a number of different error codes over the period - all similar to Error 495 (there are pages and pages of "help" out on the web).

I obviously tried all the supposed fixes for the problem - wiping data, cache, uninstalling updates for Google Play, the lot. Nothing worked.

Yesterday I finally got adb to work with one of the tablets (that was a bit of an ordeal by itself) and it finally led me to figure out what was going on.

I was running Android Device Manager and keeping an eye on the log files on the device as I was trying to install upgrades. I found the process fails with the following error:

01-23 23:25:33.869: W/DownloadManager(7289): Aborting request for download 205: while trying to execute request: java.net.UnknownHostException: Unable to resolve host "r2---sn-ab5l6n7z.gvt1.com": No address associated with hostname

This would then - eventually - result in Google Play returning an Error 495 (which in and of itself is completely useless :))

Once I saw that log entry, I manually updated the DNS server address on the tablet to 8.8.8.8 - from the DNS server that is normally used on my network.

Mind that every other workstation/laptop in the house works fine with my "own" DNS server; as a matter of fact, every other function (such as browsing the web, checking email, etc.) all work perfectly fine as well.

I therefore have a suspicion that there is more to this story than just my DNS server - somehow Android DownloadManager doesn't like mine?

Does anybody have a similar experience?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.