1

Hi to all Android Enthusiasts!

I have done something stupid :D

Some website claimed that Cyanogenmod would not work unless twrp was installed. (ChristianTroy)

I had already rooted my device (Denver Tablet TAQ-80053 ARMv7 with Android 4.1.1) so I thought why not flash to TWRP with the file: "CWM-based-Recovery-v6.0.3.3-signed.zip"? BAD idea :( I admit, this is a bit confusing since CWM and TWRP are not the same thing AFAIK. Could be another file .....

Now "Recovery Mode" is only the "TeamWin Logo" then BLACK SCREEN and nothingness ??

Everything else is working somewhat normal: 1) I can boot normally into the start screen of Android 4.1.1 and run applets etc. 2) I can connect to Windows 7 (x64) and get file access to everything.

But: Any flashing tool for windows (with ADB) cannot "see" my device, and I very much doubt it that the driver is the problem since I get full access to drives and files on the tablet (USB-connected to Windows 7 x64). Do you have any thoughts about that? To me it seems most logical that a working windows-driver would also work with ADB or am I wrong about that?

I also tried the ADB (Windows) installation with SDK etc. Everything installs fluently with no errors but when I do the "adb devices" command no devices are listed at all ?? The command "ADB Shell" returns an error.

Since I know about the settings needed on the tablet I have: set USB Debug Mode to ON and everytime I plug it in I select "Mass Storage Mode" to get file access from Windows; and it works fine.

As stated above, everything works except "boot into recovery mode" and ADB being able to "see" my device. Not even CWM Rom Manager can boot into recovery mode ??

I want to be able to flash a new OS but recovery mode seems to be the only way apart from the USB to Windows. I cannott accept the notion that the device is "almost bricked" just from installing the wrong recovery image and now I cannot go back ..... (backup got lost in the process).

I have discovered that I am not the only one with this problem but I cannot find any solution (that actually works) anywhere.

Last "development" is this: I UN-rooted my device trying to get back OTA. I think that made things worse :\

Q: Is there a way to "wipe and re-install" without ADB or Recovery Mode /Fastboot ??

/Pete

Update #1: I have tested ADB and FastBoot (Windows prompt) with two other devices, both Samsung Smartphones, and everything works like a charm. This tells us that it is definitely the tablet that's got a problem or two ;)

Upd #2: I found a log file in the cache folder on the tablet called "last_log" and one line got my attention: "TW_NO_REBOOT_BOOTLOADER := true" Isn't that a bit odd ??

Upd #3: Seems like internal sd is write protected. cwm boot manager and tw(e)rp manager cannot update files needed. bootanimation app works fine with root. that is so weird :-\

  • Given that ROM Manager and Clockworkmod Recovery are made by the same person, it's safe to assume that RM does not rely on TWRP. Have you tried different key combinations to get into fastboot mode? Or if you can re-root, run reboot bootloader from a terminal emulator as su. – Matthew Read Feb 18 '15 at 2:04
  • @Matthew Yup. I have tried both reboot and bootloader from terminal - no dice ;) – user94775 Feb 18 '15 at 23:22
2

First off, make sure you have the proper ADB drivers. Use the PDANet ADB Installer. It should install the right version of ADB.

Next, you're going to want to enable Developer Mode. To do this, open up your settings app. At the bottom of the screen (you may need to scroll), there should be a Developer Options button. Open that up.

If you do not see Developer Options, go into your About Tablet and follow these steps:

  1. Find the "Build Number" value.
  2. Tap the "Build Number" five to ten times. You should eventually see a toast saying "You are now a Developer!" or something similar.
  3. Exit out and go to the Developer Options menu.

In Developer Options, find the toggle for "Android Debugging." You want this to be on. It will ask you for confirmation. Go ahead and give it.

Now, go back to your computer and run adb devices. You should see the device there. Download whatever ROM you want to flash, and place it on your device's SD card. If you need Gapps, place it there as well.

If you still don't see your device, make sure your USB storage mode is set to PTP. Go to Storage in your Settings app and tap the menu button. Select USB Computer Connection and set to PTP.

After this, you're going to want to run adb reboot bootloader. This will place you into Fastboot mode, so that you can flash a clean TWRP.

Once you have downloaded a clean TWRP and gotten into fastboot mode, run this command from the folder that the TWRP image is in (it may be helpful to move TWRP to the folder fastboot.exe is in):

fastboot flash recovery your_recovery_image_name.img

Give it a couple minutes, and your recovery should be installed. Reboot into TWRP using the Bootloader.

If the bootloader has no such option, let the system boot into full Android and run adb reboot recovery.

When you're in TWRP, you're going to want to install your custom ROM. Consult the ROM creator for instuctions on how to do this.

  • I appreciate your effort but uhm: been there - done that :) Read again please :) Let me know if I left something out ;) There must be another way around it? – user94775 Feb 17 '15 at 20:44
  • @Pete You can't access recovery, right? If you use the Bootloader (Fastboot, not the same thing as recovery), you can flash a new Recovery image to flash a new ROM. Also, make sure your device is in PTP mode, not MTP! – Kaz Wolfe Feb 17 '15 at 20:52
  • That is correct. Recovery is a no go, and I did try Fastboot (from inside an app) and that did not work either. It puzzles me, that Windows have no problem acessing my device on file level but ADB cannot see my device?? The ADB on the device itself cannot list devices either but root is np?? – user94775 Feb 17 '15 at 22:05
  • Fastboot from inside apps will not work properly in your case. Also, part of your problem may be a lack of ADB drivers and/or your device being in MTP mode. – Kaz Wolfe Feb 17 '15 at 22:31
  • I'll try again in PTP mode but as I recall I already tried it to no avail - I'm not giving up though ;) – user94775 Feb 17 '15 at 23:07
0

It is possible to flash the recovery from within android itself without requiring any kind of USB connection. I'll get to that in a second-- First though, I am curious if you tried adb over the network (without USB). If you look at the adb documentation, you will see that there is an ADB-over-network feature (on CyanogenMod there is an "adb over network" option in Settings->Developer options->Debugging->ADB over network) I'm not sure if this is the same place in regular Android, but it's a standard adb feature, and you can find help with this online.

To get to the gist of your problem-- you basically want to do a fastboot-style flash of, let's say for simplicity "recovery.img" but without a USB connection. Effectively you want to flash an image of a partition into a particular partition, which is what fastboot does. You can do from your device without a computer, if you have the following:

  • Root on your device
  • the Terminal Emulator app
  • The recovery.img file for the new recovery you want to install. It needs to get on your device somewhere (let's say onto /sdcard/, but anywhere works. ). You might transfer this file from your computer via Google Drive (or download it with your device's browser, or whatever). Note that the file should not be a .zip; it should be the recovery image in its uncompressed .img format.
  • the busybox binary with dd compiled in (or the dd binary itself) in /system/bin. If you don't have this binary, you can find it in any CyanogenMod installation, use an app to install it, or compile it yourself. You want to have a statically-linked version so that it's self-contained and not dependent on other library files.
  • And finally, you need to know the location of your recovery partition. This is absolutely critical to get right, as you are going to dump the .img file over this partition, so you want to be 100% sure it's correct. Getting the partition wrong can have dire consequences. It might look something like /dev/mmcblk0p18 or it may look different. One way to figure this out is to look at the updater-script contained within a .zip that flashes the recovery to see which partition it flashes the recovery.img.

Once you have the above, the procedure would be something like:

  1. boot up the device
  2. launch the Terminal Emulator app and type su to get the root # prompt
  3. Use the "dd" unix command (either the standalone version or in busybox) to flash the recovery.img file into place in your recovery partition. Here's an example, assuming (1) you have dd installed, (2) the recovery image is on an sdcard, and (3) the recovery partition is at /dev/mmcblk0p18:

# dd if=/sdcard/recovery.img of=/dev/mmcblk0p18 bs=1M

The above command would reflash the "good" recovery into place, and you should be able to boot into it from there. Just so you understand the command:

  • dd : the name of the command.
  • if=/sdcard/recovery.img : this means the "infile" (the input) is the recovery file.
  • of=/dev/mmcblk0p18 : this means the "outfile" (where you're flashing) is partition 18 of the internal emmc, which in our imaginary example is where the recovery is supposed to go.
  • bs=1M : this means to use a "block size" of 1 Megabyte, effectively speeding up the flashing process.

There are more examples in the wikipedia page for dd I linked above, but the example is the kind of command that should work fine. Incidentally, dd can be used for the reverse purpose-- if there is a partition you want to back up to a file in its entirety, you can use the partition as the infile (if=) and the filename is the outfile (of=) and you've effectively copied the partition into a file...

Good luck. If you get stuck on figuring out the partition for your recovery via searching update-scripts in update .zips from the manufacturer, you may just be able to ask around in forums for your device and someone who has the device will tell you.

Another idea is to use the above technique to dd your own backup copies of the various partitions into files, then compare each of them with the bad file you accidentally flashed. If you get a match, you'll know which partition it is!

  • 1
    Even if this doesn't work your advice is brilliant. You have comprehended what my problem is, what needs to be done and how to do it! \O/ It also seems straight forward. The DD is news to me. Hope I manage to harness it ;-) I shall get back to you a.s.a.p. – user94775 Feb 27 '15 at 4:32
  • Good luck! dd is an amazingly powerful command-- it's also a little dangerous, so make sure you know exactly what your input and output paths are, because you don't want to overwrite the wrong thing! Def me know how it goes... – fattire Feb 27 '15 at 7:21
  • This is tricky alright :-| I've got 2 partitions: mmcblk0 and mmcblk0p1 and the tw(e)rp script says /dev/block/mmcblk0p4. My guess is that I should put it on mmcblk0p1 - right ?? – user94775 Feb 28 '15 at 3:39
  • I get a read error: I/O error on the source file recovery.img – user94775 Feb 28 '15 at 4:25
  • Now I have tried the normal sdcard path and it finishes without errors. Then I used 'reboot recovery' from the same terminal and it shuts down but doesn't get back. Still no recovery :(( – user94775 Feb 28 '15 at 4:58
0

I asked the vendor for the stock files plus flashing tool for PC and that solved everything. So the key thing to do in this case was to use a tool that matches the gs702a device.

FYI: I found the English versions of "Actions Pad Tools". Now I just have to figure out how to get from Android OS 4.1.1 to 4.2.2 but that is another topic in a future thread.

Case closed! ;-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy