0

Recently my Moto G2 device stopped showing text message notifications on the notification bar.

  • The device has been running on Android 5.0 (the upgrade caused no issues)
  • I am using the stock messaging app and there are no other messaging apps on my phone
  • Notifications are turned on
  • There is no option to enable or disable app notifications for the stock message app since it does not appear on on the "Apps" menu.
  • Notifications from other apps like Whatsapp are shown
  • I have not done a factory reset yet

enter image description here

I have uninstalled a dozen other apps like DU Batter Saver and Applock just to narrow down things that might be interfering with the stock messaging app. Powering off and powering back on does not work either.

I need some help.

  • If you go to Settings, More, what is set as your Default SMS app currently? – TurboFool Mar 22 '15 at 4:30
  • The default SMS app is the stock messaging app. – Prasad Shrivatsa Mar 22 '15 at 4:34
  • "it does not appear on on the "Apps" menu" › Have you checked in the "All" tab? By default, you're on the "Downloaded" tab of the app manager, which only shows apps you've installed yourself (and thus not the pre-installed ones). – Izzy Mar 22 '15 at 10:08
  • @Izzy I feel silly that I couldn't figure it out. I was indeed looking at items on the "Downloaded". After reading your comment, I switched to "All" tab, scrolled down to "Messaging" and found that "show notifications" was not checked! So, that was it. Thanks for that tip, it helped. – Prasad Shrivatsa Mar 26 '15 at 3:14
  • No prob – we all have those "silly moments" :) As it solved your issue, I've made it an answer which you can "accept" (to make this question show up as "solved"). Enjoy! – Izzy Mar 26 '15 at 7:09
1

In Settings › Apps, you have to chose the "All" tab: by default, Settings usually shows the "Downloaded" tab, which holds all the apps the user installed. The stock messaging app does not fall into that category, as it comes pre-installed – hence you'll find it on the "All" tab.

Now you've found it, you can take the approach you initially had in mind: calling its context-menu to re-enable notifications by long-tapping the entry here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.