I have got a brand new Nexus 6, and brand new LG G Watch. Everything seems to work fine, but when I try and pair them, at the final stage the watch says "Just a minute" for a long time, and then finally goes to the dialog saying "Can't connect to the Internet. Swipe for some tips."

I've followed all the tips at g.co/AWhelp (https://support.google.com/androidwear/answer/6058728?rd=1) but nothing seems to work.

The only thing non-standard about my set-up is that the phone has no SIM card. I wanted to play with Android Wear development, and so it is a test/development device.

1 Answer 1


I eventually dove deep into this, taking bug reports, and wading through them. It turns out it is my ISP. Sigh.

My home ISP is BT. BT annoyingly use a service called Barefuit to interfere with DNS, at this seems to break the Android Wear check to see if internet connection is present.

Anyway, link 17a here takes you to the BT preferences page, where you can turn this off. Having turned it off, everything works fine.

I guess this is why Google have "try using just mobile data" at the bottom of their help page. If this happens to you, and you have mobile data, then do that. If you don't have mobile data, I'd try seeing if your ISP also uses Barefruit, and complain loudly if they do (and try to turn off).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .