3

My Skype on my Android 4.4.4 used to work fine, until about 2 hours ago, when it simply refuses to use my camera, flashing a message (AKA toast) that reads:

Skype is denied to use camera

What gives?

I didn't change or touch anything in any settings that could possibly cause this. Is this a bug?

What could have triggered it?

How do I restore my Skype-on-Android's capability of using the camera?

Thank you.

  • Some devices with Kitkat can be found with Permission manager in Settings. If it is enabled and an app asks for a permission that the manager is required to scrutinize, you might have inadvertently blocked it, or could be default block for certain apps. Have you made certain this isn't your case? – Firelord Apr 19 '15 at 18:56
  • @Firelord No, I have not made certain this isn't the case. I could swear I saw such permissions manager icon somewhere but I can no longer find it. In the apps manager there is a Permission Control app (236KB), it shows as running, it is NOT disabled, but I cannot find any way to show it or invoke it. I rebooted the phone, but that didn't help. What do I do now? Thank you. – ususer Apr 19 '15 at 19:49
  • Go to Settings -> Security -> App permission. It its enabled, it could be causing it. If its not, more troubleshooting is needed. – Firelord Apr 19 '15 at 19:53
  • 1
    @Firelord Thank you! I found it. And enabled it. Turns out Skype was on Always deny. I have no idea how that happened. Interestingly, App Permissions in Security was grayed out while ON! I had to turn it off first, which got me a security warning that I am going to lose manual control over apps. I proceeded with Yes anyway, then turned it ON again, and only then I received the familiar list of permissions to control. Please post this as answer so that I can accept. Thank you. – ususer Apr 19 '15 at 20:02
  • Done posting the answer. :-) – Firelord Apr 19 '15 at 20:13
2

Some devices with Kitkat can be found with Permission manager in Settings. If it is enabled and an app asks for a permission that the manager is required to scrutinize, you might have inadvertently blocked it, or could be default block for certain apps.

To ascertain that Skype is denied the Camera permission or not, go to Settings -> Security -> App permission. Your device might have another name for it but possibly should be at similar location. See if its enabled or not. The situation might also be similar to questioner's:

Turns out Skype was on Always deny... Interestingly, App Permissions in Security was grayed out while ON! I had to turn it off first, which got me a security warning that I am going to lose manual control over apps. I proceeded with Yes anyway, then turned it ON again, and only then I received the familiar list of permissions to control.

It its enabled or similar to the one mentioned above, then either disable it or find your app into it and change the camera permissions.

  • Thank you. I don't have enough points to upvote your answer, otherwise I would. – ususer Apr 19 '15 at 21:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.