0

I've setup an SSH server on my Ubuntu desktop at home using a dynamic DNS service (NOIP). I have a wi-fi-only Android tablet running Android version 4.4.2. On my tablet I can connect to other SSH servers, such as my college's server. However, I cannot directly connect from my tablet to my desktop; every attempt times out. But I am able to connect to my college's server and then SSH into my desktop from there. Is there something I've not set up correctly in my sshd_config file possibly? I'm able to ping the public IP. But I'm at a loss to explain this behavior. I've used both JuiceSSH and ConnectBot to no avail. Thanks!

  • As per this -- On my tablet I can connect to other SSH servers, such as my college's server. However, I cannot directly connect from my tablet to my desktop; -- IMO, it should be migrated to Super User since I see no issue with Android itself. – Firelord May 11 '15 at 5:19
  • You're right, Firelord. I figured out my issue and it wasn't Android related. – rob May 11 '15 at 13:42
  • Can you post your solution and mark the question as answered? Just so others can see the question is resolved and also what the solution to the problem was :) – D. Gibbs May 11 '15 at 14:09
  • Yeah absolutely. The problem was that my router does not support connecting to forwarded ports on the WAN IP from inside the LAN. This explains why I was able to connect to my WAN IP from my college's server but was unable to connect when using the WAN IP on my local network. Answers came from this AskUbuntu post and this AskUbuntu post. – rob May 11 '15 at 14:28
0

Do you have port forwarding or access list set on your router/firewall allowing only SSH from particular IP's?

This could explain why it works from a known location.

  • No, nothing is discriminating based on IPs. – rob May 11 '15 at 1:06
  • I have a 7" tablet running 4.4.2 and installed JuiceSSH and connected to my Ubuntu 12.04lts successfully on the inside. Can you post your sshd_config file? – onthelake May 11 '15 at 2:51
  • Were you able to connect using a domain name, or using your Ubuntu machine's local IP address? I was just told that it may not be possible to connect using the domain name while I'm on the same local network as my Ubuntu machine, so I may have to run out and find another wifi network to test that theory – rob May 11 '15 at 2:53
  • Also, iptables I/F/O Chain Accept – onthelake May 11 '15 at 3:00
  • I used inside IP address. – onthelake May 11 '15 at 3:03
0

Figured it out. The problem was that my router does not support connecting to forwarded ports on the WAN IP from inside the LAN. This explains why I was able to connect to my WAN IP from my college's server but was unable to connect when using the WAN IP on my local network.

Answers came from this AskUbuntu post and this AskUbuntu post.

edit: Unable to accept answer "until tomorrow."

  • Have you tried settings your noIP hostname as the router's hostname in your network settings? – m-p-3 May 14 '15 at 16:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.