2

I have a NAS attached to my home router, and the NAS is running a web server. I would like to run the browser on my Android tablet, enter the URL (in my case, diskstation/wordpress) and get the page. This works from my PC, but if I do it from my tablet, I'm redirected to my ISP's search page (i.e. Verizon tries searching for a web site called "diskstation/wordpress").

My tablet has no SIM card, so I know I'm going through my home WiFi router. I'm not sure if I need to configure the DNS on my tablet or change some setting on my router or do something else entirely.

Can anyone help?

Thank you, Bob

  • 1
    Are you using the host name of the NAS to browse it, or its IP address? If the former, try the latter and let me know if that works. If it does, I can tell you a solution (hopefully) to access it via host name too. – Izzy May 27 '15 at 5:57
  • Hi Izzy. I'm using the host name, and that does not work. Using the IP address works. – Bob May 28 '15 at 11:57
  • OK, that was what I suspected. In this case, I have a solution for you (will post it as answer). – Izzy May 28 '15 at 13:56
1

As you can access the NAS fine via its IP address, the NAS is reachable from your Android device – but the issue is, your Android device cannot resolve its name. That is because Android, by default, always uses Google's name servers, no matter what the DHCP server tells it. You will have to override those settings:

  1. Open Settings (e.g. from your app drawer) and go to WiFi
  2. Scroll the list of WiFi APs and long-press the entry of your own WiFi network
  3. Chose to edit the entry
  4. Tick the check-mark for "Advanced settings"

At this place, you will probably see it has "DHCP" selected. To edit the settings we need to change, you'll have to switch that to a "fixed address".

  1. Switch from "DHCP" to "fixed"
  2. Check the IP address and make sure it matches your network1
  3. Make sure the "default gateway" matches the IP address of your router
  4. Change the value of "DNS1" (usually 4.4.4.4) to your name server (usually the same as your router), but leave "DNS2" (usually 8.8.8.8) untouched.
  5. Save the settings

Now try again: you should be able to access your NAS via its name, the same way you can do from your PC. As we left "DNS2" untouched, names your router cannot resolve will still be resolved via this. Once you have verified it works, you can try switching back to DHCP and check if it still keeps the changed name server, and thus leave the task of managing available IP addresses completely to your router (avoiding address collisions in the future). If switching back to DHCP brings your original issue back, you'll have to stick to "fixed IP".


1: you can find the original IP address in Settings › About phone in the status section

0

Thank you Izzy. I found another solution:

On my router (a MI424WR) I added a DNS entry for my Synology NAS. For some reason, every device on my network had a DNS entry whose source was DHCP, except for the NAS.

Now I'm able to use the NAS' hostname from my tablet. I've seen some complaints on Synology's forum that DHCP isn't working, and perhaps that's the problem I ran into. What I still don't understand is why my PC was able to use the hostname.

Also, it appears that my tablet is using my router's DNS even though I did not go through the steps you listed.

  • Bob

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.