0

Whenever I sent a message it is in

Sending...

status all the time. I've checked the SMSC settings and they are entered correctly. Restarted phone several time. Still the problem is there..

I can receive messages, can make call also

  • We may need more details. Like your phone name and model? And are you sure this is not a service problem from operator side? – Jaskaranbir Singh Jun 1 '15 at 7:01
  • My phone is Dialog i43(It is a country version from one of the telecom operators in Sri Lanka). Its not a service problem, since I've two SIMs and the problem is there in both – Fasna Jun 1 '15 at 7:03
1

The only thing that I can think of is that you're sending a type of message that can not be sent by default (e.g. MMS messages). I had an issue where long SMS messages would automatically be converted to MMS, thus not being not-sendable. Check whether the message type is SMS, and also check whether you can send short SMS messages (that won't be converted to MMS).

Also, try installing different messaging app (like Google's Messenger), to see if that helps.

  • The first message I sent was a twitter follow message. When I saw the pending status, I then tried with a just one letter messages to my other number. Then only I realized there is a problem. Will try with some apps as you suggested(Messenger is not compatible for my OS version) – Fasna Jun 1 '15 at 7:47
  • Textra worked. But, is it the solution? what is the problem with default message App then? – Fasna Jun 1 '15 at 7:59
  • 1
    Try clearing the data of the messaging app (Go to Settings > Applications > All Apps > find your messaging app and open it > press "Delete data". This might delete all your previous messages, so don't do this if you need to keep your old messages. – Aleksandar Stefanović Jun 1 '15 at 8:01
  • Clear Data doesn't dellete any of my messages. Also, the problem persists. – Fasna Jun 1 '15 at 8:14
  • 1
    I have no idea how to help you in that case... if you really need to use the defualt messaging app, maybe you should take your phone to the operater, maybe they could help you... – Aleksandar Stefanović Jun 1 '15 at 8:17
0

Remove the SIM card-> Insert the SIM into another phone and restart the phone -> Insert in back into your phone and restart and check if it works. This will reconfigure the message center and the settings for you SIM card. If the problem persist contact your network operator for settings.

  • Message center settings are configured. It works in other phones, but not in my android. That is the problem – Fasna Jun 1 '15 at 7:09
  • 1
    Have you also tried installing any third party apps like textra and in Messenger app..? – Lucky Jun 1 '15 at 7:42
  • Textra worked. But, is it the solution? what is the problem with default message App then? – Fasna Jun 1 '15 at 7:58
  • @Fasna great..Have you tried clearing the default Messaging app data and cache? – Lucky Jun 1 '15 at 8:00
  • yeah, it doesn't work either :( – Fasna Jun 1 '15 at 8:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.