Yesterday there a bunch of app updates, I didn't pay much attention to which ones, there were perhaps 8 or 10. Since then my phone has shutoff and/or rebooted unexpectedly at least 8 times. 4 times it's gone through a full "optimizing apps" cycle, which take 30+ minutes. Two of those optimizing apps cycles resulted in a premature shutdown.

Today there was an Android System Update, 16.1mb, which I applied. Thankfully it seems things are more stable now, with only two shutdowns, but that's not enough of course.

I decided this is enough of a kick for me to finally do a full reset and root the device. I'm trying to do a Full Backup of non-rooted devices but am stuck. The phone asks for "current backup password" but I don't know what that is. I don't remember setting one, but I may have. I did do an adb backup about a year ago.

Phone with 2 password prompts

I tried the on-boot de-crypt password, but that's not it or at least nothing happens on the PC side after entering it and then tapping the "back up my data" button.

How do I reset the backup password?

Phone is Nexus 5, 16gb.


3 Answers 3


My little research here indicates that the current backup password is saved in the file /data/backup/pwhash (no plain-text). In some earlier Android versions removing that file followed by a reboot resulted in paving a way for setting up new password since current password would default to blank then. But in Lollipop, you've to remove the file pwversion (in the same directory) as well.

Because the location is under /data/ you'd get "permission denied" message if you attempt to browse into /data/backup, be it from a file manager or from command-line, unless root access is provided.

The only way (as it seems to me) to reset the password without root access is the factory reset.

  • According to ES File Explorer /data folder is empty . I tried creating a /data/backup folder and got an "operation failed" error. Attempt to create "new folder" in same location got a differently worded operation failed message. So I surmise the folder is there but hidden because no root access. (I was hoping perhaps if I could read the file I'd somehow glean enough info to uncover the password. Faintest of faintest hopes, I know!) Sep 15, 2015 at 22:56
  • Does Nexus 5's stock recovery gives access to ADB shell? You may try your luck from there.
    – Firelord
    Sep 15, 2015 at 23:07
  • I decided the work of attempting to get in through ADB shell and any consequent actions is greater than the pain of losing and recreating whatever data and preferences are not saved in the "backup to cloud" set. So, I'm resetting the device to ground zero. Sep 17, 2015 at 17:52

I just wanted to check in here and report what worked for me, i just had the same problem. (Im running LineageOS on a Fairphone 3, but I think this should be pretty transferable for android in general, lmk). After seeing Firelord's answer (props, this is a great lead), I enabled developer options, debugging over usb and root debugging and connected my phone to my laptop w a usb data cable (confirm that you have a cable for data and not just power, this is important).

Install adb on your laptop. You can then connect to your phone and reset your backup password with the following cli commands (you shouldnt need a rooted phone to do any of this):

adb root

adb shell

This will open up a shell session on your phone from your laptop, then:

rm /data/backup/pw*

Then reset your phone. Your "desktop full backup" password should now be blank, and you can set up a new one. Since youve already come this far, consider connecting w adb again and running 'adb backup' to download a backup to your laptop for future use - I personally find this to be a safer and more convienent option than juggling sd cards or ftp or whatever.


Keep the "Current password" box blank and apply your new password.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .