1

Usually I just install superuser.zip through recovery. But now nothing happens. I tried using TWRP both from NAND and from SD (latest version with F2FS support).
I try to root this rom: SLIMLP LP5.1.1 based on CM12.1 for HTC HD2.

Looks like the recovery wants to install superuser on NAND always.

I can install superuser application like apk, but root did not work this way. But with adb shell I can get root access. And from screenshots I see in thread people have root. I want to use superuser with this ROM. How do I go about doing it?

3
  • UPD: I tried mount two sd_ext partitions before installing superuser, but no changes at all. Also tried change buildin su binary with superuser su binary in rom archive and flash. (permissions are correct) Still no root. Tried install supersu with recovery too. Maybe someone can ask dev in xda thread about rooting, tried with different vpns and proxy, several e-mail but xda think I'm a spammer. Also wrote support about problem with registration, no reply.
    – Anonymous
    Nov 17, 2015 at 13:12
  • Please specify device and Android version in the question itself, since this may be a device specific issue. Nov 21, 2015 at 9:48
  • Also, the ROM is probably already rooted. In CM based ROMs, there is a built-in Super User privileges manager, access it through either Developer Options or Superuser settings under Settings. It is not recommended to flash SuperUser on a pre-rooted device, because it leads to a whole host of problems. Nov 21, 2015 at 9:52

1 Answer 1

0

It was easier then I thought. I just need activate Developers options and under Developer section activate root. Video: https://www.youtube.com/watch?v=Knm1kKVkJd8

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .