I just upgraded my new Moto G3 to Marshmallow and noticed that both of my screen capture apps (AZ Screen Recorder and Lollipop Screen Recorder) no longer worked. I kept getting stuck at one dialog asking for permission to capture the screen.

impassable dialog

Cancel still works, but it wouldn't let me select Start Now at all.

  • 2
    Your issue seems similar to this issue. This usually happens when there are apps that overlay your screen. Check this post to determine which apps, and try to disable/kill it. – Andrew T. Feb 4 '16 at 6:26
  • I have no idea which ones to disable though. Some in that list I need. – ifconfig Feb 4 '16 at 7:45
  • You can try disable the permission of the apps that you install & recognize first and left one of the recorder enabled, then try using it. The feature is not critical, meaning that disabling the permission won't break your phone. However.. I might be mislead by the similar issue; it might not caused by screen overlay, which I don't have any clue right now... – Andrew T. Feb 4 '16 at 8:35

Its very simple brothers.. you cannot click "start now" or if u trying to install any 3rd party application you cannot click "install" on moto g4 device .. its because you all people enabled "filter applications" like "blue filter"

Please disable that and enjoy

  • 1
    I get what u mean, but a reword would be nice (Kids, He's saying at you can't press start while a screen filter or dimmer is enabled.) – Dan Brown Nov 29 '16 at 21:31

I figured that LuxLite was causing the issue. Disabling its access to drawing over apps temporarily allowed me to clear the dialog and get it working.

  • 1
    Can you explain how to disable LuxLite, thanks. – Maxime Feb 26 '16 at 7:50
  • Sure! Go to settings, search for draw, and click on the option that says "Draw over other Apps", scroll to the application you want to disable draw access for (Lux Lite in this case,) click on the application and deselect the switch for the permission. That's how to do it. – ifconfig Feb 27 '16 at 17:00
  • You can also disable Lux by tapping the power button icon in its notification. Or, you can go to Lux's Settings > Advanced and uncheck Enable Lux. Both of these methods have the same effect as revoking the permission, just with less steps – Andy May 24 '16 at 2:04
  • @Andy possibly. I never thought of that... – ifconfig May 24 '16 at 2:40

I'm guessing the apps don't implement the new Marshmallow's permissions at runtime correctly. Try to give those two apps all the permissions yourself:
Settings -> Apps -> (click app name) -> Permissions -> click any unchecked permission.
If all the permissions are already checked and you still face this problem, I bet you need to wait for an update; you could try meanwhile to contact the developer and report the issue.

  • This answers a secondary issue about permission at runtime. However, the real issue is, there's seemingly a running screen overlay that prevents critical dialog to be confirmed (cannot tap "Start Now") – Andrew T. Feb 4 '16 at 5:46
  • @AndrewT. from the information in the question, I'm just guessing. That dialog shown in the picture is the app dialog (not the Marshmallow's native permission dialog), so I bet the Start Now button gets clicked, but at that point the code assumes the permission to be active, while maybe is disabled. Therefore my answer. I'm guessing here, but doing as I suggest could tell us I'm right or wrong in my guess. I don't think anything prevent Start Now to be tapped, just the consequences of the tap are ignored by the app - I think. – Alessio Feb 4 '16 at 5:52
  • 1
    That dialog is actually Marshmallow's native permission dialog (I have tested it on Android 6.0.1) for screen capture. In fact, I checked the app on permission manager (just now), all of the permissions are already enabled, so this answer won't actually solve the issue... – Andrew T. Feb 4 '16 at 5:56
  • I don't think that dialog is Marshmallow's native permission dialog, as that can't be customized [1]. With "Marshmallow's native permission dialog" I mean the one which prompts when you call ActivityCompat.requestPermissions(): "Note: When your app calls requestPermissions(), the system shows a standard dialog box to the user. Your app cannot configure or alter that dialog box." [2] 1. stackoverflow.com/questions/33266328/… 2. developer.android.com/training/permissions/requesting.html – Alessio Feb 4 '16 at 6:05
  • "all of the permissions are already enabled, so this answer won't actually solve the issue" -> if so, then my guess is wrong, and my answer is useless. +1 – Alessio Feb 4 '16 at 6:08


Switch off your phone

Go to recovery mode by pressing power button + volume down

Fine 'clear cache/partition' by voume keys

Select yes by power key

Now simply reboot your phone...

Tadaa...! Problem is solved


This is mostly due to permission management. My suggestion is to download access management app and see whether the screen recording app has the right permission. Or root the phone. I have the same problem as you and solved it by rooting.

Not the answer you're looking for? Browse other questions tagged or ask your own question.