1

I wanted to pair a bluetooth device (specifically, Dynamo Harvester) with my Moto G 2 (Android 6) with the normal workflow: Open bluetooth system settings, scan for devices, select Dynamo Harvester, enter the PIN and it is paired.

Now, after entering the wrong PIN (0000 instead of 000000) several times – where most of the time a message was displayed that the PIN was wrong –, I entered the correct PIN, and something strange happened. The Incorrect PIN message popped up for a brief moment, and afair the device moved to the list of paired devices.

Since the app still did not recognize the Dynamo Harvester, I turned bluetooth off and on again. Now the device has disappeared from the list of paired devices, but appears in the scan list. If I try to pair, I cannot enter a PIN anymore but receive a message Can't communicate with Dynamo Harvester.

I thought that perhaps the device is broken somehow, but connecting with a Samsung Android tablet worked just fine (with the correct PIN).

What can I do? Might this even be a bug in Android because of the strange message about the incorrect PIN, although it was correct?

Bluetooth; can't communicate with Dynamo Harvester

  • 2
    Did you read the FAQ? You don't pair it in System Settings like a normal BT device, you have to pair it in the app... "Some Bluetooth devices are to be paired in the system settings. However, de Dynamo Harvester is paired in the Setup menu of the app". be-on-bike.de/en/harvester/faq.html#BLUE1 – acejavelin Jun 22 '16 at 15:26
  • Thanks @acejavelin! Yes, I have tried many times, with no success, and then tried to pair it in the settings instead. So I guess this can be closed … @Izzy thanks for resizing the image! – Simon A. Eugster Jun 22 '16 at 18:48
0

I recently had a similar problem though different devices (Android Google Nexus 7 running Marshmallow and Motorola Buds Bluetooth headset). Turns out the headset needed a reset to forget all the devices it had learned. Since I switch between devices, I suspect my data in the headset itself had become corrupted. In any case this fixed my problem. You might try finding a headset reset for your device and see if that fixes your problem. You may also need to have your phone/tablet forget all the devices, too, as that has helped me in the past.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.