0

Below I discuss SuperSu as an example but I suspect there are more apps affected as well.

I go to open SuperSu and discover that its nowhere to be found.

  • I tried GoogleNow launcher
  • I tried Nova launcher
  • I tried searching for it on both launchers

To complicate things further, it still manages my phone, I still see SuperUser grant permission boxes or requests for root access.

plaY

  • Ive checked for it being disabled, uninstalled, or frozen and its not
  • Ive checked the MainActivity for being disabled but its not, also tried disabling and re enabling the MainActivity to no avail

I then tried restarting the phone which also didn't work

The only way I have managed to open it is through ADB shell access

am start -n eu.chainfire.supersu/eu.chainfire.supersu.MainActivity

Once manually opened it runs just fine but glancing at the RecentApps icon list, SuperSu has no logo/icon, its an empty placeholder with SuperSu text below it

enter image description here

I'm now growing concerned that there may be several other apps who are the same way and after rumaging through google for a while now I cant find any answers

My only theory thus far is a running optimization program by 3c toolbox that runs on boot which Ive disabled and trims partitions, cleans cache, and optimizes databases which I didn't even know 3c was doing that so disabled immediately but not sure if its relevant or not. My last hope is just re-installing the entire system but I'm hoping to avoid that

0

Well I found SuperSU in the settings menu. I don't mind it there but it did throw me off as I do remember it being in the apps list and being searchable.

So I'm not sure if it's suppose to be in both or not but for the time being I'm marking it as answered.

If this is still not normal and it's suppose to be in both places or searchable let me know here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.