1

I have a Sidekick 4G running 2.2.1.

I've had a problem with both stock and custom ROMs randomnly losing the BT connection to my Plantronics Pro headset. Sometimes hitting the connect button on my headset will reconnect it, but eventually it always loses it permanently and I have to unpair, delete it and then re-pair it. If I try to just re-pair, I get this message: "Unable to pair with PROPlantronics. Incorrect PIN or password."

This is, needless to say, hugely annoying and oft times very inconvenient (such as when I'm driving and discover my headset can't be used).

Anyone have an idea of how to fix this? I never had this problem with the headset on either my G1 or my og Droid...

1

Seems to have been a common problem with Plantronics Pro Voyager series headsets, not specific to Android.

0

If you are sure that the Bluetooth device works perfect with other devices, and you have tested with stock- and custom-rom. Then you have only got one option left, deliver your smartphone for repair/guarantee.

3
  • I'm not sure that's it. I've googled and seen others with similar issues on other phones, but no resolutions. I think it may have to do with the version of Android I'm running.
    – Logos
    Dec 3 '11 at 12:04
  • why not try to update your android version? if there isn't a newer version for your device, i would recommend Cyanogenmod
    – patchie
    Dec 4 '11 at 12:30
  • CM isn't available for the SK4G, or I would be running it :( The hardware profile is unusual, and no one's reverse engineered the drivers for it yet. I'd say I'm an intermediate level power user, and none of the obvious solutions have worked so far, alas. Hence the question here.
    – Logos
    Dec 4 '11 at 15:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.