The Album app on my phone fails to detect some of the pictures I have after I moved them. I tried clearing the Album app's data but it didn't do anything. After looking around the internet, I found that one way to refresh media apps is to find the Media Storage system app on the Settings and then clear it's data. After I did that, I noticed my notifications on some messaging apps stopped having sound. When I tried to select a new notification tone for it, I found out that all the default ringtones and notification sounds are missing. Is there a way to get this resolved like maybe there's a directory where these tones are placed in the system, or am I SOL?

After digging around, I found my notifications, ringtones, and alarm sounds are still in /system/media/audio/ but for some reason the ringtone selection dialog doesn't detect them. They don't have a .nomedia on the folder so it can't be that. Is there a way to force them to be rediscovered?

  • 1
    Restart device, wait for a few minutes for the database to be indexed again
    – beeshyams
    Jun 22, 2017 at 12:38
  • I could've sworn I've restarted multiple times to no avail, but I'm probably having false memories. I'm restarting now to see if it does the trick. Will update.
    – user400424
    Jun 22, 2017 at 12:41
  • Also see if clearing cache helps
    – beeshyams
    Jun 22, 2017 at 13:17
  • Back after 30 minutes, still nothing. I've rebooted the phone already. What app should I clear the cache to?
    – user400424
    Jun 22, 2017 at 13:23
  • Tough luck. Clearing cache is the same way as you cleared data. Long pressing on Storage of that app should show both options
    – beeshyams
    Jun 22, 2017 at 13:37

1 Answer 1


I had the exact same issue, I can't remember why but I know I cleared my media storage when trying to fix something. Of course, the guide I was blindly following never mentioned that it would silence my alarms as a byproduct 😱

Using the search "Media Storage" android tones gone, I found some good resources that led me to the ScanMediaPlease app, which forces the process to reindex the stuff. The app worked where rebooting failed for me.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .