I have a Samsung Captivate, running the stock Froyo ROM, rooted. When I try to install a large app from the Market, I get the error "insufficent space on the device", for apps of ~40 MB, with 700+MB free. I first noticed it with "Jelly Defense" on Google's Christmas-week sale, but you can see it for yourself if you try the free "Reiner Knizia's Labyrinth" which is also quite large.

This is a common problem -- just Google it and you'll see dozens of posts around the Internet going back almost a year. From those posts, I've tried two free apps that are supposed to help, "Market Fix" and "Cache Fixer", but neither has done the trick yet. As I understand it, both are supposed to re-mount /cache as a loopback file on the SD card. I don't know why they don't work. If anybody has fixed this specifically on the i9000 series (SGS1, Captivate, Fascinate, etc), please let me know how!

  • I had this on my Vibrant and now that I think about it I think it went away after I cleared the cache. Interesting. Jan 8, 2012 at 21:12

2 Answers 2


Always the way, innit? 5 minutes after I ask, I stumble across this. It's not super elegant but its success is in its simplicity. Simply replace the dedicated /cache partition with a link to the internal SD card, and Bob's your uncle. Has to be repeated on reboot, so not perfect, but way better than not installing at all!


The reason you're getting that error is because your /datadata cache is filling up. The way I solved it on my phone was to get the MarketFix app from the market, and run that. It's a small app, so you shouldn't have any trouble downloading it. This probably does the same thing you found, but you only have to run it once.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .