1

I installed LineageOS on my Moto G1 (falcon) and after using it for a couple of weeks my phone restarted and got stuck on boot. I cleaned the cache in recovery mode but it didn't help. Afterwards, I reinstalled LineageOS and the problem went away but it happened again after a couple of weeks. Using logcat during the boot process gives me the output below. It seems to be stuck in WiFi initialization due to an error. The WiFi initialization error keeps repeating every couple of minutes. Has anyone seem something similar or has any possible workaround? I don't want to reinstall the OS every now and then.

Regards.

- waiting for device -
--------- beginning of main
02-15 09:13:01.048   178   178 W auditd  : type=2000 audit(0.0:1): initialized
02-15 09:13:02.560   178   178 I auditd  : type=1403 audit(0.0:2): policy loaded auid=4294967295 ses=4294967295
02-15 09:13:02.560   178   178 W auditd  : type=1404 audit(0.0:3): enforcing=1 old_enforcing=0 auid=4294967295 ses=4294967295
02-15 09:13:06.111   189   189 I         : debuggerd: starting
--------- beginning of system
02-15 09:13:06.194   190   190 I vold    : Vold 3.0 (the awakening) firing up
02-15 09:13:06.195   190   190 V vold    : Detected support for: exfat ext4 f2fs ntfs vfat
02-15 09:13:06.223   190   195 D vold    : e4crypt_init_user0
02-15 09:13:06.223   190   195 D vold    : e4crypt_prepare_user_storage for volume null, user 0, serial 0, flags 1
02-15 09:13:06.223   190   195 D vold    : Preparing: /data/system/users/0
02-15 09:13:06.230   190   195 D vold    : Preparing: /data/misc/profiles/cur/0
02-15 09:13:06.231   190   195 D vold    : Preparing: /data/misc/profiles/cur/0/foreign-dex
02-15 09:13:06.232   190   195 D vold    : Preparing: /data/system_de/0
02-15 09:13:06.233   190   195 D vold    : Preparing: /data/misc_de/0
02-15 09:13:06.235   190   195 D vold    : Preparing: /data/user_de/0
02-15 09:13:06.236   190   195 D vold    : e4crypt_unlock_user_key 0 serial=0 token_present=0
02-15 09:13:06.240     1     1 I vdc     : 200 192 Command succeeded
02-15 09:13:06.277   196   196 I /system/bin/tzdatacheck: tzdata file /data/misc/zoneinfo/current/tzdata does not exist. No action required.
02-15 09:13:06.346   197   197 W batt_health: type=1400 audit(0.0:4): avc: denied { read } for uid=0 name="power_supply" dev="sysfs" ino=5990 scontext=u:r:batt_health:s0 tcontext=u:object_r:sysfs:s0 tclass=dir permissive=0
02-15 09:13:06.353   197   197 E BHD     : Could not open /sys/class/power_supply
02-15 09:13:06.353   197   197 E BHD     : acPath not found using default
02-15 09:13:06.353   197   197 E BHD     : usbPath not found using default
02-15 09:13:06.353   197   197 E BHD     : batteryPath not found using default
02-15 09:13:06.353   197   197 E BHD     : Battery not valid
02-15 09:13:06.353   197   197 E BHD     : Failed to validate battery after 1 attempts
02-15 09:13:06.354   197   197 E BHD     : NVM Read - Can not open /pds/batt_health/batt-0123456789abcdef_0, errno = 2 (No such file or directory)
02-15 09:13:06.354   197   197 E BHD     : NVM Read - Can not open /pds/batt_health/batt-0123456789abcdef_1, errno = 2 (No such file or directory)
02-15 09:13:06.354   197   197 E BHD     : No valid NVM files found
02-15 09:13:06.389   199   199 I sysinit : Running /system/etc/init.d/0000liveboot 
08-18 20:22:15.277   682   961 I WifiHAL : Initializing wifi
08-18 20:22:15.281   682   961 E WifiHAL : virtual int WifihalGeneric::handleResponse(WifiEvent &): QCA_WLAN_VENDOR_ATTR_FEATURE_SET not found
08-18 20:22:15.281   682   961 E WifiHAL : nl80211: requestResponse->nl_recvmsgs failed: -5
08-18 20:22:15.281   682   961 E WifiHAL : get_firmware_bus_max_size_supported: requestResponse Error:-95
08-18 20:22:15.282   682   961 E WifiHAL : Failed to get supported bus size, error : -95
08-18 20:22:15.460   682   995 I WifiHAL : event received NL80211_CMD_VENDOR, vendor_id = 0x1374, subcmd = 0xa
08-18 20:22:26.892  1400  1577 I WifiHAL : Initializing wifi
08-18 20:22:26.895  1400  1577 E WifiHAL : virtual int WifihalGeneric::handleResponse(WifiEvent &): QCA_WLAN_VENDOR_ATTR_FEATURE_SET not found
08-18 20:22:26.895  1400  1577 E WifiHAL : nl80211: requestResponse->nl_recvmsgs failed: -5
08-18 20:22:26.896  1400  1577 E WifiHAL : get_firmware_bus_max_size_supported: requestResponse Error:-95
08-18 20:22:26.896  1400  1577 E WifiHAL : Failed to get supported bus size, error : -95

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.