0

Up until yesterday I was able to read imported .txt files with the resident File Manager. The files were imported over USB direct to the root directory of the internal SD card via copy-paste. Now it won't open the files, giving an error saying "open file failed".

I didn't knowingly change anything. There's no way to uninstall the file manager, no way to update it, it's embedded in the tablet which is really frustrating. I deleted and imported the files again and still get the same error. I called Asus tech support and they weren't able to help other than tell me to download another file manager. I downloaded Tetra Free but it comes back with a text box asking me "Open with" but no options are displayed.

I'd really like to use the resident File Manager. Any ideas out there what I can do?

  • Can that file manager show the file permissions? If so, please check what they are set to. Furthermore it might help to edit your question and include how you've copied those .txt files to your Android device. – Izzy Aug 30 '17 at 9:00
  • The resident File Manager does not allow me to edit permissions, at least as far as I can tell. I copied the files over through a USB cable to the root directory, as I always have. – Eric Graves Aug 30 '17 at 9:21
  • Didn't ask about editing permissions, just checking :) And by "via USB cable" you mean using MTP, or via ADB? By "root directory" you mean the root of your SD card, I assume. Internal or external (slight differences in permission management, hence the question)? – Izzy Aug 30 '17 at 10:06
  • I hooked my pc to the tablet via usb and copy and pasted to the internal sd card, as always. I'm very curious what has maybe changed with permissions, maybe OS, maybe the File Manager app itself, overnight, with no interaction on my part. – Eric Graves Aug 30 '17 at 18:44
  • From your description I assume then you did that via mtp. It might be worth checking if, failing to open the files, the file manager writes something to the logs. To find out, you could take a look into our logging tag-wiki. You could also consult Settings › Apps on whether your file manager app received an update (if it has a button to "uninstall updates", you could try that and see if it helps; if it doesn't, you can always apply the update again). – Izzy Aug 30 '17 at 20:50
0

Have you tried "Droidedit"? It is an app on playstore that is used by programmers to code but it can read your txt files.. I use it when I code batch files...

OPTIONAL: Smanager, Root Browser, WPS office

Good luck! :)

  • I'm really hoping to make the File Manager work like it always has. It's baffling and kind of infuriating to have it be so difficult to get it back to where it was. – Eric Graves Aug 30 '17 at 9:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.