8

I seem to have lost the auto focus capability on my Nexus. The phone is stock, only one update done (so it's XWKL2). I don't use the camera much, but I think I had auto focus when I first started using the phone. Now I have to manually focus by tapping the screen.

I'd rather not clutter my phone with 3rd party apps for camera since I don't use it much, but I'd like to have AF for my random quick snaps.

Any tips?

2
  • Did you try resetting the settings to defaults? There is a reset button in the setting menu (open camera, the setting knob, then the three dots, restore defaults). If that doesn't work, then go to system's Settings and clear application data.
    – Lie Ryan
    Mar 17, 2012 at 0:26
  • @LieRyan Tried both, didn't change a thing... Mar 20, 2012 at 8:03

6 Answers 6

3
+100

These suggestions might seem odd and they might not yield any results but they're worth a shot:

  1. Try using the panorama and video settings in the stock camera, and I do mean actually use them. Don't just switch to them and switch back to picture mode. If you're lucky changing modes, taking a panorama/video, then changing back to normal picture mode will reset whatever needs to be reset.
  2. In normal picture mode long-press the shutter button. Try this twice, one time release the screen as normal and the next drag your finger away from the shutter button before releasing the screen. I'm not sure if doing it these two ways will have different results, but I know that if you drag your finger away no picture will be taken.
6
  • 1
    Actually, after taking a panorama shot I noticed a slight AF shift when taking the next picture, but that was it, couldn't reproduce and the AF didn't "lock", just tried to focus but couldn't. Mar 21, 2012 at 4:56
  • Well that's progress at least. Are you on Verizon? I ask because there's a rumor circulating on the tubes that Verizon's Galaxy Nexuses are going to get an update to 4.0.5 some time in April. With any luck this will correct your problem if you can't figure it out before then.
    – newuser
    Mar 21, 2012 at 13:03
  • Nope, I'm Finnish and the phone has no operator customization, pure stock. Mar 21, 2012 at 13:05
  • The 4.0.5 comes from Google, not Verizon, so there won't be any additional carrier customization. Still, Google considers 4.0.3 to be "base" ICS. What version are you running?
    – newuser
    Mar 21, 2012 at 13:08
  • I'm running 4.0.2, since 4.0.3 hasn't been officially released over here for some reason. Mar 21, 2012 at 13:16
1

Try this, Go to Settings -> Apps -> All Tab -> Camera -> Clear data.

1
  • Tried this, still gives just the "tap to focus" option... Mar 20, 2012 at 0:40
1

Did you try resetting the settings to defaults and rebooting the phone? There is a reset option in the camera setting menu (open camera, the setting knob, then the three dots, restore defaults). If that doesn't work, then go to system's Settings, Applications, "all" tab and clear data.

1
  • Yes, tried both of these, didn't help. Mar 21, 2012 at 4:54
1

If you tried clearing the app data, resetting to defaults, changing modes and did a factory reset than the only thing left to do is take it back to where you purchased it so they can have a look at it and fix it. It's entirely possible that you have a hardware failure.

1

What happened with my phone is that the scene selector got set to Landscape by an OS update or someone else fiddling with the phone and I didn't even know that there was a Scene selector. Once I found this setting I found that if I set it back to Auto (or Macro if you want to do a close-up) that the auto-focus starting working again.

Hopefully this helps someone.

2
  • And, for our enlightenment, how can others find this setting?
    – ale
    Jul 24, 2012 at 12:04
  • @AlEverett On my phone, I would open the camera (app) and then slide the menu open from the right. There are 4 options, from top: 1. Scene 2. Effect 3. Flash 4. Switch to. Select the first one which is Scene.
    – Guy
    Jul 25, 2012 at 16:05
1

Did you clear the camera app data?

To do this:

  1. Open your settings app

  2. Tap the "Application" section

  3. Tap the "All" tab

  4. You can find the camera app. Select -> Clear App Data

If this not works, here is anthoer solution for you!

Reset the camera settings

To do this:

  1. Open the camera app

  2. You can find the camera knob. Press it -> 3 dots menu -> Reset Defaults!

Any help you will accepted!

Thank you so much!

Hope this helps for your Android device!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .