I have the TELUS Samsung Galaxy S2 X (T989D) running Gingerbread (v2.3.5). Today my friend (who has the Samsung Galaxy S2 (TI9100)) told me that they changed the Android Market to Google Play. I opened my Android Market to see if it would update to Google Play and all I got was a message asking to accept the terms of Google Play, which I pushed "Accept". After trying the following to have it updated to Google Play, still no cigar:

  • Deleting data and cache
  • Removing and reinstalling all previous Market updates
  • Turning off WiFi and using only 4G
  • Rebooting phone (several times)

I dont understand why its just not updating like everyone elses is? Maybe it has to do with the model of my phone?

EDIT: I also forgot to mention that I am in Canada.

2 Answers 2


From the official announcement on the Android Developers blog (emphasis mine):

We’ll be rolling out Google Play to devices in a phased OTA update, starting today and continuing over the days to come. With the update, the Android Market app will upgrade to the Play Store app and the Music, Videos, and Books apps will upgrade to Play Music, Play Movies, and Play Books. This update is for devices running Android 2.2 or higher, and users on other devices will continue to have the same access to your apps as before.

Just give it some time to work. For what it's worth, I got the upgrade almost immediately after I read the blog, and the new Google Play appeared in the apps instead of the old Market. It's pretty much the same as the previous Market app, bar the new branding. Also, check the version of your market app -- Google Play is version 3.4.6 or later, the old Market is 3.4.4.

  • Thanks Martin. I guess I will have to wait for it to get updated. I checked the version of the Market app and its 3.4.4, so I guess I am just 2 behind from the current one. Mar 8, 2012 at 18:54
  • I went into the Market today and it finally updated to "Google Play". I guess TELUS was just a little slow to get the update. Mar 8, 2012 at 22:34
  • Just wondering if anyone with a HTC Desire running the 2.3.3 upgrade that HTC begrudgingly release last year has managed to get Google Play onto their phone. I've tried the steps above but I still have the regular market. I get the feeling we've been abandoned and are expected to get slightly faster phones which are 7% more shiny (for another £500 or so) but I remain optimistic.
    – user5506
    Mar 21, 2012 at 12:45
  • @Poldie: I do have a Desire, but with CyanogenMod 7.1, and I got the new market very quickly. AFAIR, Market updates are pushed by Google in their own discretion and are not dependent on device makers or carriers. Mar 21, 2012 at 12:49
  • I might check it out. Last time I looked at CyanogenMod the instructions were scary. Noone seemed to agree on how to perform the steps; the included links to other sites (with no guarantee whatever was being pointed at was still relevant), required downloads from file sharing sites etc. I'd do it in a heartbeat if it were simple but I can't risk bricking my phone for (by all accounts) a new icon to load a freshly renamed market. Or is it simpler now?
    – user5506
    Mar 21, 2012 at 12:57

If your device is not detecting an update yet there is manual update as well.

You just have to download apk from the link and install it in your device.

Here is a link: Google Play Store 3.9.16

Note: After installing apk to your device if app started force closing

  1. Clear data from app i.e go to settings->manage app->play store->clear data
  2. If it is still force closing reboot your device

This works for me hope works for others as well

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .