I recently bought a case for my Archos 101 9G Turbo, which has a built-in USB keyboard, but I can not make it work by simply connecting the usb cable from the keyboard either the micro USB port (with and adapter) or the normal USB port. The tablet shown in the photo is not the Archos, but it is right to illustrate the example. My case

As you can see, the case has an USB cable coming out of the keyboard. I updated the tablet firmware to the new ICS 4.0 so maybe it is a drivers problem and I haven't found the solution on the Archos forums.

My approaches are:

  1. The keyboard works because I plugged it into my computer.
  2. The tablet USB also works because I plugged in an USB hub with a LED screen and it received energy (both via micro usb and via normal usb activating the 3G option).

I read that maybe it is a power consuption problem because when the keyboard is plugged in the built-in lights (for example, the upper case key) don't work. I have also tried to plug in a mouse and nothing happens.

I wonder if anyone else had this problem and how he solved it. Should I use a bluetooth keyboard?

  • Is this an official Archos case? More info on the keyboard would be useful. Commented Apr 18, 2012 at 20:25
  • It is not an official product, but can connect via USB cable and I tested it over a Windows machine without problems. I have no much info about the keyboard than that it works via USB. I read that all my problems with the Archos are due to the fact of having gone from 3.2 to 4.0 without a previous full format (the tablet also freezes and some apps crashes eventually) Commented Apr 19, 2012 at 6:44
  • I know that this is a very common problem between Archos users, not only the USB drivers problem, but the fact that the tablet freeze itself and some apps do not work (I can play a few seconds of BIA2 and then bang! a crash...). Archos suggested me to format the device, to reinstall the latest firmware (4.05) but this didn't solve anything. Despite of this issues, usb memory sticks are working! No one has found a solution (new firmware, or maybe I need an specific Archos keyboard, mouse...)? Commented Apr 26, 2012 at 7:49

1 Answer 1


Archos deals with a special USB host cable for USB OTG. Perhaps you need it.

  • So you are forced to buy the host cable from the Archos store, right? Pfffff, I'll try it and then I'll tell you the result hehe. Thank you anyway. Commented Jul 26, 2012 at 12:48
  • You were right. Buying the Archos cable solved the problem and now my keyboard is working perfectly. Commented Aug 1, 2012 at 21:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .