0

In Android Studio V3.5, I created some AVDs which are based on Intel x86 CPU. But I failed to start any of them because any HAXM devices couldn't be found.

I have enabled VT-x in my BIOS setting. When I tried to install 'Intel Hardware Accelerated Execution Manager V7.0.5', it reported "failed to configure driver unknown error. failed to open driver.".

My PC is Windows 7 64-bit. I couldn't find any solutions.

So, is it possible to disable HAXM feature for an AVD based on Intel x86 CPU?

0

The Android emulator.exe has a lot of command-line options.

The one you need is -accel:

-accel <mode>

Valid values for mode are:
  auto - Determine automatically if acceleration is supported and use it when possible (default).
  off  - Disables acceleration entirely, which is primarily useful for debugging.
  on   - Force acceleration. If KVM or HAXM isn't installed or usable, the emulator won't > start and prints an error message.

Therefore you should use -accel off

For more details: https://developer.android.com/studio/run/emulator-acceleration.html

| improve this answer | |
  • Thank you sir. But in general, we start an AVD in the AVD Manager other than command line. In fact, I tried to find some option for this in myAVD.ini. But I failed to find any. – Johnson Sep 7 '19 at 4:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.