Any changes I make within aCalendar (e.g. adding an event, changing the calendar for an event, adding or deleting a calendar) aren't reflected within the local Google Calendar app or from the Google Calendar website. The changes may be reflected in other calendar apps on the same device (e.g. Business Calendar). Moreover, opening one of these other calendar apps may cause the changes to propagate to the local Google Calendar app and the Google Calendar website. Within aCalendar's "Manage calendars" screen, the Google Calendar account has "io-error" next to it.

The phone is connected to WiFi and the cell network. Account sync is turned on for the Google account, and synchronization is enabled for Google Calendar. Data saver and battery saver are enabled.

How can I get aCalendar to synchronize its changes?

System info: LG V20 Android Oreo 8.0.0 Google Calendar 6.0.56 aCalendar 2.2.7

1 Answer 1


aCalendar's help docs ("General Sync Issues / Sync of two devices" and "Problems with Google Calendar Synchronization") list a number of settings to check, including:

  • background data
  • energy/battery/power saver

In particular, if the phone's energy saver mode is turned on, background apps are restricted. aCalendar relies on Google Calendar running in the background for synchronization, so energysaver mode thus interferes with calendar synchronization.

To get calendar sync to work, go into the energy saver settings and exclude/exempt Google Calendar. It should not be necessary to exclude aCalendar or other calendar-related apps (e.g. Calendar Storage).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .