I have a new HTC MyTouch (32A) that I tried to install a new ROM on using ROM Manager. I have done this many times (maybe 100 times), once in a while it goes wrong. Now, with this one, it can't get to the recovery, that is, it can't get past Fastboot. So, I am trying to install a ROM from Fastboot.

I know Fastboot is working:

mojotexas@Starjammer ~ $ fastboot devices
SH06EPB01384 fastboot

I have a good ROM that I cooked up in Android Kitchen. It is called: signed_101110_220528.zip

WHen I try to install this ROM using Fastboot, I get an error:

mojotexas@Starjammer ~ $ fastboot update 
archive does not contain 'android-info.txt'
archive does not contain 'android-product.txt'
error: update package has no android-info.txt or android-product.txt

So, what are these txt files, where do I get them, and where to I put them in the ROM?

Alternatively, how can I use fastboot to install a clockworkmod recovery and go from there?

Thanks, m0j0


5 Answers 5


Can you not download the image of the clockwork recovery here: http://www.koushikdutta.com/2010/02/clockwork-recovery-image.html

And do something like:

fastboot flash recovery /path/to/<recovery>.img 
fastboot reboot 

Note: I've never done this via fastboot before, I've always done it via ROM manager so take my advice at your own risk.

  • I rooted my LG GT5450 device and installed ROM mananger but when I am click on flash ClockworkMod recovery it doesn't display my device model. now what I do?
    – RobinHood
    Jul 30, 2011 at 10:38
  • i did "sudo fastboot flash recovery /path/<recovery>.img" and i got OKAY.. but then got.. FAILED (remote: (InvalidState)). what does this mean?
    – robnardo
    Jan 25, 2015 at 22:50

ROMs installed from fastboot on HTC devices are different from the ROMs one installs through recovery. Their contents are images that need flashed along with a couple .txt files that the phone uses to verify that they're built for your phone. If the phone isn't NAND-unlocked/S-OFF, they also have to be signed. Take a peek at the RUU for your particular phone from this XDA thread to see how they're structured.


i have a method that i created. install a recovery that utilizes sideload as the boot img with mfastboot flash boot.img literally name the recovery as boot.img and flash it.

then once in the recovery using adb type adb devices it will start a com port

start sideload on the device

using the cmd type adb sideload customrom.zip done!

obviously the custom rom filename will be whatever rom you use.

i just unbricked a bootlooped moto g textnow wireless phone with this all by accident because nothing else worked.


I had the same problem here: archive does not contain android-info.txt. Tried google but can't find anything.

Finally I copied the update.zip to my devices sdcard and "applied update from sdcard" – that worked.


Don't do update. Do a command in the following syntax:

fastboot flash [system/recovery/boot] /path/to/recovery/image.img

Example: fastboot flash recovery /mnt/sdcard/Download/twrp.img

I HIGHLY recommend not flashing images to system or boot partitions without a custom recovery first. You should only flash recoveries via fastboot.

  • 1
    Do you have any basis for your "recommendations"? Apr 27, 2016 at 2:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .