1

I am trying to pull a file from my phone (Blackberry Key2 / And 8.1) and it fails with exit code 1:

[host] admin$ adb pull /system/bin/app_process ./ ; echo $?
1

I confirmed the source file exists, and I have have write permission to current folder, and to /tmp, but it always fails for file "app_process". I tried pulling a simple text file from /sdcard/test/myfile.txt to /tmp and that works. So for some reason app_process won't pull!

I restarted adb daemon, confirmed phone is in developer mode (and all options permitted) , restarted the host (Mac), ran adb with sudo, etc. No difference, and no error message.

I am running adb v1.0.41, version 30.0.5-6877784 on Mac OS

I saw this post that suggests it might relate to a symlink, but trying to pull app_process32 (which is a file) has same issue.

How do I solve or debug this? (This command is part of the final build process so this command has to work)

5
  • /system/bin/app_process is globally accessible. You can use Termux to copy the file to /sdcard/ and then pull from there. Jan 15 at 15:13
  • yes shell works, and I can copy that file around in the shell. I can use (termux) or other alternatives, since this command is run from another program that builds my app
    – TSG
    Jan 15 at 18:26
  • I did that already. I could pull a text file (from /sdcard no problem)
    – TSG
    Jan 15 at 20:30
  • I confirmed it does not exist on host. I am running command from an empty directory
    – TSG
    Jan 16 at 14:03
  • adb exec-out 'cat /system/bin/app_process 2> /dev/null' > app_process
    – alecxs
    Jan 16 at 15:52
1

The cause was surprising, but poor error reporting even more frustrating. My devices is connected using USB, passed through to a VM. It seems USB timing issues cause the connection to be intermittent or out of spec. But not enough to cause an error in system log.

abd do not complain about the latency or loss of connection, just quietly died with error 1. Switching to a TCP connection from USB resolved the problem

2
  • 1
    still no explanation why adb pull app_process fails but adb pull myfile.txt works
    – alecxs
    Jan 18 at 8:21
  • It seems to be intermittent. The myfile.txt was a very small file, so that's probably why it did xfer long enough to timeout
    – TSG
    Jan 18 at 21:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.