1

TL;DR

Trying to sideload Lineage, I hit a brick wall getting the following error:

D:\Setups\XXXXX\Lineage FP3\platform-tools_28.0.2(ADB_1.0.41)>
    adb sideload lineage-17.1-20210104-nightly-FP3-signed.zip
adb: failed to read command: No error

The phone displays Timed out waiting for fuse to be ready. simultaneously.

Setting:

I'm trying to install LineageOS on my Fairphone FP3+ using Windows 10. Through workarounds including first difficulties and exploiting the manufacturer flash all .exe, I was able to boot the Lineage recovery and start sideload. adb devices returns the following:

List of devices attached
A2XXXXXXXXX1    sideload

The phone display prints Now send the package you want to apply to the device with "adb sideload <filename>"...

Problem:

I now enter adb sideload lineage-17.1-20210104-nightly-FP3-signed.zip, paying attention on having the archive in the same folder as adb (that's the default way, even if about to change). The result was

  • either adb: failed to read command: Connection reset by peer with aparent restart of the recovery boot
  • or a adb: failed to read command: No error in the cmd, giving me Timed out waiting for fuse to be ready. on the phone. I don't trust that error as it doesn't time out by waiting but in an instant after sending the sideload command.

I also double checked and cross-switched the cable, USB port, downloads, software versions (Lineage and recovery/ADB), as well as un- and reinstalled all respective drivers.

More references:

I also went through these possibly related questions on this site among others:

1
  • 1
    sideload is broken, adb push file to /cache /data or /tmp – alecxs Jan 18 at 13:31
1

The solution in this very specific case seems to have been reinstalling the host OS (in my case Windows 10). I suspect it to be a driver issue of some sort as the reinstallation of everything used the exact same setups, files etc. I could guess into some of the multiple DisplayLink-ish software I tried to use for my tablet as secondary USB PC display. (Such as Superbrush, Super Display, VirtualTablet, WiredXDisplay, spacedesk and so on, I tried a few.)

While this is not a direct answer to the question, I hope, it could help other people stuck like me. The exact same procedure led to the desired, previously blocked resullt.

TL;DR:

Try a different host device or new installation (of the host OS) instead of giving up!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.