0

Situation : My phone battery drains out completely one day and even after charging it fully the phone is still stuck in boot-loop with Nexus 'X' logo.

What I did : Tried factory reset from recovery mode multiple times but no luck. I tried to install factory 4.3 as well as 4.2.2 using adb sideload but constantly get the error.. "Signature verification failed". I checked the md5 checksum for my downloaded file and it seems fine.

What am I doing wrong here ? Amongst the images downloaded in a .tgz file what is the the file I should be using for sideload ?

Note : I am using xubuntu to run the adb command

2

You can't install a ROM using adb install, just like you can't install a fresh Ubuntu system with apt-get. You use fastboot to install new ROMs, when the device is in fastboot mode. Instructions are different for each device, and the ROM you downloaded should come with them.

Regardless, from the symptoms you describe, it doesn't sound like installing a new ROM will help with the problem. Before trying anything so drastic, check the tag wiki to see some more triage/debugging steps you can try.

0

Updates : I did fastboot all the images and the 4.3 image using adb. No errors but was still stuck at the 'X' logo after while booting. Next I tried to flash the twrp recovery and clockwork recovery image so that i could sideload the image.zip. But was still getting the verification failed error. On closer look at the logs of clockwork i found these :

"cant partition non-vfat: datamedia
cant format unknown volume: /external_sd
cant format unknown voume: /emmc"

Have I done any damage to the memory ?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.