I have bought a SAMSUNG A10s phone and tried to install TWRP according to this instruction. I was able to unlock the bootloader and enter the 'Downloading' mode.

I disabled time sycro and automatic updaten, set the time to a few weeks ago and connected the wifi in order to overcome this issue.

I used a Debian computer and the Heimdall tool to flash this TWRP image into the recovery partition (which replaced the existing recovery.img, I took no backup - daft, I know).

Caused by the unlocked bootloader I got a warning with every startup. The usual key-combination for the bootloader menu did not work. So, after a few boot procedures, I tried the offered option to lock the bootloader and perform a factory reset.

Unfortunately, this brought me to bootloop. I was only able to enter the 'Downloading'-mode again. Now, the bootloader is locked again but the images are invalid. I get this error message:

Partition recovery
Reason recovery: Eroor verifying vbmeta image: invalid vbmetaheader
SAMSUNG recovery, A107FXXU7BTL1, 36415554R
SAMSUNG vbmeta, A107FXXU7BTL1, 36415554R

Quitting this 'Downloading' mode brings me back to the loop which reaches the SAMSUNG logo before it boots angain.

Can anyone explain this situation? Has anyone an idea for a solution? Using Heimdall, I can still read the PIT. So, maybe I can also flash any images. I am very glad for help!

Current state: locked in the Downloading mode

  • 1
    Does this answer your question? How to use ODIN with more than a dozen of mbn, bin, img, ext4 files?
    – alecxs
    Feb 22 at 21:18
  • 1
    after unlocking bootloader (and necessary factory reset) one must connect wifi and oem unlock again to disable vaultkeeper
    – alecxs
    Feb 22 at 21:20
  • 1
    be aware bootloader is not downgradable, therefore i recommend to flash U7 as higher bootloader level may lead in non-unlockable bootloader
    – alecxs
    Feb 22 at 21:30
  • 1
    yes that is your current bootloader level i am refering to. i don't know which stock ROM you have downloaded but there might be a risk after flashing latest available version your bootloader is locked down entirely and the 7 days trick won't work any longer. therefore flash oldest possible stock ROM (which is U7 already in your case) android.stackexchange.com/questions/234025/…
    – alecxs
    Feb 22 at 21:36
  • 1
    but vaultkeeper is a different story - basically just don't forget to unlock bootloader twice before actually flashing custom binary
    – alecxs
    Feb 22 at 21:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.