My phone is Gionee S10C and I have Android 7.1.1 installed on it.

I was going to upgrade the Android version to 10, but Gionee no longer provides OS updates(Not sure whether the company even exists now), so I tried to flash Lineage OS 17.x from this site.

I connected the phone via USB cable, opens up command prompt on Android platforms folder and run adb reboot-bootloader to enter the bootloader screen of the phone.

And then I tried to run fastboot flash -w system lineage-17.x.x.img.

After rebooting, my phone is not longer running, but completely bricked. It keeps stuck in the Gionee logo screen and keeps rebooting when entering the Recovery screen.

I tried factory reset, but that didn't work out.

FYI, I forgot to run fastboot oem unlock.

The worst case is that I can't find the device on Windows, which means adb devices returns nothing even the phone is plugged in.(fastboot devices in the bootloader screen shows the device)

So now I'm going to re-install the original Android OS on the phone, so that I can use it, but no method works because of adb disconnecting.

I tried the steps from this site using various Flash Tools, but no tool can find the connected phone.

All I can do now is to use fastboot.

(I was going to use fastboot flash to overwrite the system partition with the one from the original ROM, but there are too many images for the system like system1.img, system2.img, .... - I don't know which one to use).

This is the files I have in the original ROM firmware.

enter image description here

Please advise me how I can get back to my original Android or install any other Android OS, so that I can use this phone.




You must log in to answer this question.

Browse other questions tagged .