3

My Samsung i9000m running 2.3.3 stock ROM from Virgin Mobile Canada (unlocked) suddenly won't display web pages. This happens on all websites. It sends the request, waits for about 5-10 seconds (at about 1/5 of the progress bar), and returns a blank page (clearing the progress bar). No error is displayed. It behaves as though the operation has completed. It leaves a white screen and no scrolling. (Like an empty HTML page.)

All other apps are fine. e.g. Google Maps downloads all its data AOK. I can even tether wirelessly to my laptop and browsing is fine there, too. So I deduce that the data is getting to the phone.

I installed Dolphin to see if it was specific to the default browser. Dolphin behaves exactly the same way.

I'm also a beginner Android developer. Could this be a failure in WebView? It sounds to me like any data received is ignored.

Short of rewriting the stock ROM is there any way to fix this? Has anyone else seen this behaviour before?

6
  • 1
    This may obvious, but have you tried turning it off and on again? I doubt that it's a WebView issue. You could try Firefox or Chrome Beta which AFAIK use their own renderer.
    – Flow
    Jun 8, 2012 at 13:02
  • 1
    Have you tried clearing the data of the browser app?
    – ale
    Jun 8, 2012 at 13:09
  • I had this issue on the default browser on my Nexus S except it only happened intermittently, the upgrade to ICS fixed it.
    – Peanut
    Jun 8, 2012 at 14:48
  • Yes, I have "tried turning it off and on again" (in my IT Crowd voice) and cleared all the data. The only thing I haven't done that's data-related is to wipe the ROM and start again. Jun 9, 2012 at 0:49
  • @Peanut I can't see why ICS would make a difference. This is 2.3.3. Do you think 2.3.3 unstable in this regard? Besides, I'm looking for ways to fix it without reROMming the whole thing. Jun 9, 2012 at 0:50

1 Answer 1

1

After months being annoyed by this, I rerommed the device and it was ok after that. So I can only suppose that something core had become corrupted.

1
  • 1
    You cannot check now anymore, but a factory reset might have solved it. Stupid as it sounds, but that's why support staff always tells that if they don't know anything else to try. Sometimes something gets messed up where this is the only solution (except re-flashing, which would include all which factory-reset would do). Besides: Thankx for provideing your solution!
    – Izzy
    Aug 14, 2012 at 20:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .