0

Bought a 128G card I meant to use as mixed internal / portable (or 100% if not possible with mixed) on a

  • Galaxy-Xcover-4 (SMG390F)
  • Android version 9
  • Kernel 3.18.91
  • Not rooted (Though I could do it I guess, if there's any method and it is the only way to reach the goal).

First I tried to see if it was possible to do from Phone, but did not find any.

Then I did:

adb shell
sm set-force-adoptable true
sm partition disk:179,32 mixed 34
sm set-force-adoptable false

It got partitioned, but did not increase internal memory + using the elipsis on SD card view (Settings -> Device Care -> Storage -> SD Card) only crashed. Tried to reboot. But to no avail.

Then I deleted the partitions and re-inserted the card. It asked about formatting the card, and I did; but it is all portable. (I.e. System / Internal is not increased.)

Then I tried same adb session as above but with sm partition disk:179,32 private (I.e. use 100% of SD-card as internal). This also formatted SD-Card, but now it is not recognized at all.

Re-booted, but still the same.

Is there a way forth to make it increase internal storage?

The phone only have 15G natively and I am constantly pushing close to 100% usage.

6
  • If its becoming complicated I think you should mount bind somefolders in internal storage to folders in external storage and move the files to the respective folders or simply sysmlink them.
    – Silent
    Dec 19, 2021 at 21:06
  • @Silent: One can do that on un-rooted device? Problem is apps. I have all media (including photos) on SD. Dec 19, 2021 at 21:08
  • Could you mention the Android version and the encryption status? According to GSM Arena, looks like Samsung Galaxy Xcover 4 starts with Android 7.0 and is upgradable to Android 9.0. There's a warning on Android Developers that on devices encrypted with FBE on Android 7.0-8.1, external SD cannot be used as adoptable storage. Only since Android 9.0 that adoptable storage can be used with FBE.
    – Andrew T.
    Dec 20, 2021 at 3:02
  • @user3342816 actually it needs root sorry.
    – Silent
    Dec 20, 2021 at 3:08
  • @AndrewT. It say "Android version 9" under Software information. (It does not say 9.0 though, but guess it is). Dec 20, 2021 at 16:53

0

You must log in to answer this question.

Browse other questions tagged .