I bought this Samsung Galaxy M12 (SM-M127G/DS, Exynos 850, 6000 mAh battery, India version) about 11 days ago. Since then I have been dealing with this RMM state issue, struggled to find a way for OEM unlock to show in developer options, and then root the device but no luck, no fix, or whatever.

Things I have tried:

  • Waited 7 days (+168 hours) after signing in to my Google and Samsung accounts.
  • Factory reset 3 times so far.
  • Tried the change date and time trick.
  • Tried the update trick.

After all of these, nothing worked, so then I thought that maybe removing Knox via ADB will solve this issue.

Is it possible? Will it damage the device? Will it solve this issue?

  • Is the device you use branded by a mobile network provider? Where did you buy the phone, are you sure it is genuine (really an Galaxy M12)?
    – Robert
    Apr 29, 2022 at 11:08
  • @Robert what do you mean by branded? As far as i know its carrier unlocked since everything is fully functional(I can make calls and everything works fine except this issue). I think its genuine. It came boxed with everything inside even the documents. Here is the link to it.
    – Silent
    Apr 29, 2022 at 12:03
  • Branded means that a special firmware is installed that has been modified by a mobile network operator that e.g. includes special apps from MNO or provide a special radio firmware optimized for the MNO.
    – Robert
    Apr 29, 2022 at 13:30
  • no its not branded. It just has bloatware netflix and samsung pay mini.
    – Silent
    Apr 29, 2022 at 17:50
  • @Robert I went into download mode and checked, the culprit is reallly Kg state. It says kg state prenormal which proves why the oem unlock disappeared.
    – Silent
    Apr 30, 2022 at 20:21

1 Answer 1


Finally it has happened enter image description here

What i did was connect to wifi and the oem toggle came up. So i think it all comes down to region or your isp which you use to connect to the rmm servers. Yeah it appeared with 4 hrs uptime, which means the date change tricks dont work anymore on android 11.

The steps im recommending to use although not exactly tested:

After factory reset, connect to a vpn with the server of where your phone was launched(or try switching ISPs), check for updates to register the phone and pray that the next time you connect to your wifi your rmm status would have changed. If the server you tried doesnt work also, try a different server after a factory reset.

I hope this procedure helps someone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .