I have an Xperia x10i running firmware version 2.1-update1 from 3 (a very annoyingly-named mobile service provider). After returning from a trip, I have noticed that certain applications are having difficulty recognizing the availability of a network connection, while others function just fine. The cases I have spotted so far:

  • After spending a good while on "Loading...", the Facebook app displays "No Internet Connection. Try Again"
  • The Youtube app immediately displays a popup stating "Attention: There is no network connection right now. Please try again later." on startup. Attempting to view any type of information from youtube (e.g., "favorites" or "most viewed" lists, not just videos) causes this same error to be displayed.
  • The Google+ app can retrieve and display Notifications or members of my Circles just fine, but attempting to view posts leads to a long "Loading..." display, followed by "Google+ connection lost."
  • Searching and browsing work properly in the Android Marketplace app, but any attempt to install or update apps results in the downloads almost immediately going into "Download paused" status and staying there for hours, aside from the occasional attempt to restart the download (which invariably ends in re-pausing it), until I kill the Marketplace app.

Despite this, other apps work just fine - Browser will run searches and bring up pages, the Google Calendar widget updates properly, etc. These results are consistent regardless of whether I am on a 3G or wi-fi network. "Data traffic" is enabled under Mobile Network Settings. Both "Background data" and "Auto-sync" are enabled in Accounts & Sync Settings.

What do I need to do to get this working again?

2 Answers 2


Try this:

Menu > Settings > Wireless & Networks > Mobile Networks > Data Enabled (that should be checked).

Menu > Settings > Wireless & Networks > Mobile Networks > Access Point Names, hit menu, tap on 'Reset to default' :)

  • My phone calls it "Data Traffic" rather than "Data Enabled", but I flipped that off and back on, then reset AP Names to default. This seems to have gotten Youtube working on 3G, but not on wi-fi. All other apps that I mentioned continue to not work on 3G, nor do they work on wi-fi. Jun 24, 2012 at 14:34
  • Wow! That's unusual... mind me asking - what was the last app you installed - no need to mention it here on the forum, am trying to get you to think if you installed anything recently during your trip. If not, it sounds like roaming has clobbered something (hard to believe I know) Do you have a recent backup of the APNs prior to the trip?
    – t0mm13b
    Jun 24, 2012 at 14:37
  • The latest installed app is either "RD Mute" or "Silent on Charge at Night", but I also installed a few other similar apps at about the same time, then deleted them after deciding that I preferred these two; that was all about a month before my trip, but the apps I'm having problems with aren't ones I use that often, so I can't say for sure whether they worked post-installation/pre-trip or not. Unfortunately, I have no recent backups of my phone. Jun 24, 2012 at 14:48
  • It sounds like one of the apps have messed up something somewhere or not cleanly un-installed, ie. left some residue data somewhere... last resort (I'm not advocating this) factory reset it to get it back again...unless you have titanium backup and use that to clean up via Menu > More > "Clean up the dalvik cache" (from within Titanium Backup) - one question- is handset rooted?
    – t0mm13b
    Jun 24, 2012 at 15:35
  • Yes, it is rooted. OTOH, there's an Android update available that I've been putting off (I haven't looked to see whether it's staying in 2.1 or going to 2.2/2.3) and this would be a decent excuse for getting around to installing that upgrade. Jun 24, 2012 at 15:52

Check the date and time under Settings. YouTube and some other apps report no network when the date is wrong.

  • To downvoters: This answer might lack some details, but also contains a valid advice: if the date/time settings are too far off of reality, SSL connections fail as they might encounter certificates which are either "not-yet-valid" (system time too far in the past) or no-longer-valid (system date too far in the future). Apps using "unsecured channels" (http instead of https) would be not affected, so this would perfectly match the in some apps, but not others from the question. This should not be reported as "no network", but error messages might be misleading.
    – Izzy
    May 14, 2014 at 11:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .