0

I have a Xiaomi Redmi Note 9 (128GB/4GB RAM). I have unlocked my bootloader. Then I tried to install TWRP. I got into the fastboot mode, then executed:

fastboot devices
fastboot flash recovery [file].img
fastboot flash vbmeta [file2].img
fastboot flash misc [file3].bin
reboot

or something like it. And when I push the volume(-) and power buttons while rebooting, it just reboots into the Xiaomi logo, again. I can not even turn it off.

Now, it is stuck on a bootloop showing the Xiaomi logo. I am unable to boot into the bootloader. When I connected it to the PC and tried to boot into the bootloader -with no success-, the PC made the sound of something being connected but it quickly made the sound of something being disconnected.

What should I do?

Note: I am a complete newbie in this.

I went to different repair shops and they told me it needs software or worse a new ROM.

3
  • "I am unable to boot into the bootloader" - how do you try to enter bootloader mode? Have you tried pressing Power+Volume while booting?
    – Robert
    Oct 23, 2023 at 11:21
  • I tried pressing Power+Volume "down " while booting Oct 23, 2023 at 11:24
  • And what commands did you execute to get the device into that state? Please edit your question and add all the commands.
    – Robert
    Oct 23, 2023 at 11:34

2 Answers 2

2

I fixed the phone. I got out of "EDL stuck". I bypassed the authentication. Then I used SP Flash Tool to flash a new ROM using a firmware upgrade. Its bootloader is locked again. Now the phone is unbricked.

1
  • Where could I find a tutorial on how to do that? thank you.
    – montelof
    Nov 27, 2023 at 16:00
0

Your phone has a MediaTek chipset, and there is a tool available on GitHub called MTKClient, which you can use for this purpose. This procedure is irreversible so you should read well and comply strictly with the instructions of the manual. I recommend deleting the recovery partition and then rebooting the device using python mtk e recovery command.

1
  • How will this solve my problem, can u explain? Oct 26, 2023 at 19:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .