I've got a Nexus S phone. It was never rooted or modified. It currently runs the most recent version of Ice Cream Sandwich (that was installed as an Over The Air update, without any issues).

Couple of days ago I received a notification from my phone about Jelly Bean upgrade being available. Unfortunately every time I try to install it there is a problem. The phone reboots and starts the upgrade process, but after about 30 seconds it stops and displays an image of a red triangle with an exclamation mark. When I press power+volume up to see what happened, this is the message it displays:

Finding update package...

Opening update package...

Verifying update package...

Verifying current system...

assert failed: apply_patch_check("/system/etc/gps.conf", "[random letters and numbers - probably a hash]", "[different combination of random letters and numbers]")

E:Error in /cache/9ZGgDXDi.zip

(Status 7)

Installation Aborted.

I tried "wipe data / factory reset" and "wipe cache partitions" options, but the issue persists.

  • I bought the Nexus S last year in November with 2.3.6. Two weeks later it was updated to 4.0.3, the next update was 4.0.4 sometime in June and finally to 4.1.1 last week, without the error you described.
    – ott--
    Commented Jul 26, 2012 at 14:48
  • Yeah, I do realize most people don't have this problem. The question is what do I do now... Commented Jul 26, 2012 at 16:32
  • Had you applied any GPS patch earlier?
    – roxan
    Commented Jul 27, 2012 at 3:39
  • Have you already contacted Google's spport? Is the system still working with ICS tho?
    – ott--
    Commented Jul 27, 2012 at 9:14
  • 1
    Might be worth a shot in getting a flashable zip to install the gps.conf file into /system/etc? it could be corrupted and thus the patching of it failed
    – t0mm13b
    Commented Jul 27, 2012 at 23:50

2 Answers 2



After quite a bit of research I am now able to answer my own question. I was able to clean install Jelly Bean (in opposite to the usual method of upgrading) using official images posted by Google. This obviously solved the issue.

Here are my instructions how to do this.


This looks like the file didn't download properly. Are downloading the file over wifi or mobile network?

If over mobile network, try wifi, and if wifi try mobile network.

It looks like the file is corrupt and cannot be flashed - try opening the file on your computer or by using a file manager on your device.

You can also try and use desktop update software.

  • I downloaded the package multiple times. It seems to me the error message doesn't point to a problem with a update package (the "Verifying update package..." phase went ok), but with a file on my current system (the problem happens during the "Verifying current system..." phase). What do you mean by "desktop update software"? Commented Jul 28, 2012 at 11:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .