I was trying to create ext2/ext3/ext4 partitions on the SD card. I tried ClockworkMod recovery and it didn't work. Nothing seems to have happened.

I also tried using MiniTool and that also failed. I tried both Disk Utility and GParted in Ubuntu and it still didn't work. For MiniTool, Disk Utility, and GParted, after I finished partitioning the partitions showed up on the computer OK, but when USB's disconnected the One X says that the SD card's corrupted.

Has anybody done this? Or is there some other way to solve this?

Or maybe it's not possible because the SD card is built-in?


After some more playing around, it seems that the problem might be something related to a partition table.

When there's no partition table, it works fine, but after I add a partition table it seems that the phone can't recognize the SD card anymore.


I think this post provides some information about it. It also seems to be consistent with what I've tried.

Instead of partitioning the SD card, mounting an .img with a ext4 filesystem is a simple workaround.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.