I use Opera for Android but the same problem exists in the stock browser as well as Mozilla. Until about a week ago I could play videos from the web in the browser but now when I click on the video instead of starting to play I get the option to use the stock video player, SoapCast or the browser to open it and if I chose the browser it downloads it instead of playing it.

Does anyone have any idea what I am doing wrong?

Thank you. I want to play videos in Opera again.
I have Android 2.3.4 running on an Xperia Ray.

  • same is true of dolphin HD and firefox
    – Para
    Aug 26, 2012 at 19:14
  • Are all of the affected videos of the same type -- e.g. Flash? Can't you play any videos? Did you install/uninstall any video related app around the time it stopped working? From your description I take it the browser is mentioned in the list of choices. In the screenshot provided with the answer of power-inside, you see a checkbox for a default action -- you could try to mark this, and then select the browser, so you would not be asked again (try befor without checking it if it then plays as expected).
    – Izzy
    Aug 27, 2012 at 22:30
  • @Izzy If I check the browser as the default action(and this is only possible for Opera because the stock browser or dolphin don't show up in the list) The browser downloads the .flv file instead of playing it like before. All .flv files have this problem except youtube because youtube videos open in the Youtube application this has always been so.
    – Para
    Aug 28, 2012 at 15:37
  • and you have no idea what you might have changed around that time? App (un)install, played with configs, whatever? Things like that usually don't happen "just like that".
    – Izzy
    Aug 28, 2012 at 16:12
  • @Izzy I remember installing SopCast and updating Flash(that pretty much happened on it's own I just oked it). I uninstalled SopCast. Don't know how to rollback Flash if that is even possbile. And I don't know if they are related.
    – Para
    Aug 28, 2012 at 16:20

3 Answers 3


This is because you have installed some other apps that are capable of opening the same media. Previously, only your stock video player was associated. Now I guess SoapCast can open it.

This is how android works normally, but if you want the old behavior at all times, select the checkbox that says "Use by default for this action" and then click on the stock video player or "Movies".

Complete Action dialog box

  • You don't understand I don't want to play them with the stock player this is what is happening now. Before I played them in the browser itself. This is how I wanted to be from now on as well. I don't like playing them in the stock player for a number of reasons. I want to play them in the browser. I did install SopCast at one point and SopCast was in the "Complete action using" list but I removed it since. Removing it did not fix the problem.
    – Para
    Aug 28, 2012 at 15:40
  • @Para Oh.. I've never been able to play/stream "inside" the browser. Maybe your stock browser has some plugins that did it? Tried resetting the data of Browser (restore factory settings for it?)
    – Irfan
    Aug 29, 2012 at 15:16

Well I kinda' fixed it. I changed the user agent setting in my Opera browser from Mobile to Desktop and every flv file now works.
As you might expect there are side effects(I'm getting dektop sites instead of mobile sites - they are bigger, harder to use and they take up more space so they load slower).
This will be a good work around at leas.

  • I think I actually had the user agent set to desktop and that is what really happened
    – Para
    Sep 2, 2012 at 13:27

You could try to use Default App Manager to remove the association for flash video (.flv) files. This should tell the browser(s) to play the video without to open a new app.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .