alt text

I always got this error when trying to connect my Galaxy S to my PC in Kies mode. I can connect it as "Mass storage" with no problem. But I need to connect with Kies mode to get 2.2 (froyo), but I always get this error. What is this error and how can I correct it?

I have Windows 7, Galaxy S 2.1, and kies already uploaded to the latest version. If this is of help, the PC tries to install "MTP USB Device" for a while (around 3-5 minutes) and during this time the phone shows a display that says "Initialising blah blah, press home to exit".

How to fix this? Or if this is possible, is there another way to upgrade to 2.2?

9 Answers 9

  1. Go to Samsung Kies software, on top left of the window, click the menu > Driver recovery.
  2. Let it reinstall drivers
  3. After driver installation finished, go to your phone, Settings> Application > Development, tick USB debugging mode.
  4. Under USB debugging mode connect your phone to the PC with USB.
  5. It installs correctly!
  6. Disconnect from PC
  7. Untick USB debugging mode
  8. Connect again

and it works!

  • Thank you very much for sharing, but this SGS MTP thing is getting annoying, and there is several ways to fix it, yet there isn't a specific way to do it, what worked for me may not with for you, your way worked with my friend's handset and my way didn't :) Commented Dec 6, 2010 at 0:17
  • yup. Thank you once again for your answer, unfortunately it didn't work for me :( I still upvoted it though
    – Fitri
    Commented Dec 6, 2010 at 12:13
  • How do follow this process with the latest Kies software? btw and OT: this is my first android experience -- not fun
    – CVertex
    Commented Apr 5, 2011 at 12:54
  • What worked for me was uninstalling the Windows 7 driver in device manager then reconnecting the device and letting the device driver reinstall. then kies sees the device - yay
    – CVertex
    Commented Apr 5, 2011 at 13:01
  1. Uninstall Kies and all drivers, then reboot.

  2. Download and install the appropriate drivers from this XDA post.

  3. Download and install Kies Mini from Samsung.com (Support at the top, then just select your phone model and go to software).

  4. Connect your phone!

  1. Back up your data, all of it, internal and external SD memory.
  2. Connect your phone to your PC choosing the Mass Storage option (first make it ask you before connect how to connect), then walk through all of your applications checking for any folder named cache or anything similar, then delete whatever is in it.

If you came across any other kind of file that is cache or related to cache, delete it.

This issue happens because some, most of them actually, cache files have a very long extension , and that prevents the MTP connection establishment.

For me, I tried this in two ways, the first one, I formatted my SD memory, both internal and external, and that didn't pay off, then I tried the method I mentioned above and it worked, if it didn't please reply telling so.

  • how can I back it up if I can't connect to PC? How do you know which file is related to cache and should be deleted?
    – Fitri
    Commented Dec 1, 2010 at 16:59
  • back up all your contacts on your SD card, you can do so from settings or so. and there are lots of application in the market for backing up your contacts, texts and so. Commented Dec 1, 2010 at 17:07
  • Connect in Mass Storage mode, copy all of your data on your PC, keep in mind that this won't back up your application or contacts it's merely for saving your files, then browse through your handset folders, cache files are located in folders called "cache", e.g. you have an application called XYZ, open its folder, most probably you'll find a folder called cache, delete the files from the cache folder. Commented Dec 1, 2010 at 17:12
  • ok copied all folder called cache, and it didn't work. I even created a program that moves all files with filename length > 16 to outside of the SD card, and it still doesn't work. Do I need to remove long named folders too?
    – Fitri
    Commented Dec 2, 2010 at 13:51
  • 1
    sorry I tried removing all suspicous files but it doesn't work. However I found another way that work. Will post that as an answer
    – Fitri
    Commented Dec 5, 2010 at 4:53

Found the problem to be like one of the guys said in another thread. It was the external SD having most likely unrecognized characters (at least to Samsung Kies) or characters that are too long.

I removed the external SD and ran Kies and it's working. It might not be very useful to do it this way but I only needed it to update SW and manage contacts so its find.


The hint from Omar proved to be the best for me. I found out that a wallpaper app installed long extension files in my SD card and I happened to find a sub-folder named "cache" inside the folder carrying the app´s name. Once I deleted it and reinserted the usb cable onto the phone, "voilá", the PC recognized it again on MTP mode!!


I resolved my Galaxy S connection problem on Win XP 32-bit by installing the Microsoft_User-Mode_Driver_Framework_Install-v1.0-WinXP.exe.

Edit: I think this has been replaced by the Windows Driver Kit.


I have done a lot, including uninstalling Nokia-related phone apps, switching to debug mode and usb mass storage mode for getting different drivers. The 18 mb exe located in Samsung\Kies\USB Driver extracts many folders including .inf, but none is for MTP driver. The driver reinstalling option from Kies also doesn't help.


I switch back to the default home screen, not launcherpro, not HeLauncher, but TwLauncher, I get the 'MTP Application' screen on phone showing 'Connected' immediately. If this screen doesn't come up, it's impossible.

So my final piece of advice is to restore your phone to factory setting and see if it's a problem related to what you have in internal sd. (external sd removed of course)


I had the same problem with my device. A problem lied in the running apps that avoided the phone going to the standby mode (for me it was e.g. my K-9 email client).

Therefore, I shut these apps down, connected my phone again to my laptop and it was ok.


No need for any backup or any formatting your SD cards.

All you need to do is,

  1. Connect your phone. When it says failed go to Device manager and uninstall it from there.
  2. Unplug your phone, go to Kies, open tools → install drivers.
  3. After installation plug your phone.

Tested on Windows 7 x64 Ultimate only.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .