I have two wi-fi networks at home and one of them I just cannot connect to with my Galaxy Nexus. (It works fine with several laptops.)

It shows up but when I try to connect after "Connecting..." it just goes to the state "Saved, secured with WPA2".

I also tried connecting using WPS but it just times out.

I am looking for ways to get additional information to debug this.

What I have tried (as suggested in many other places) is changing the frequency band from Auto to 5 or 2.4 GHz but that didn't help. EDIT: By now I have also tried resetting the phone but that didn't help either.

  • Did you check the WiFi channel used as well? Not all channels are (lawfully) valid for all countries, and some devices are stricter than others dealing with those regulations.
    – Izzy
    Dec 27, 2012 at 13:40
  • No, I didn't were can I find those setting?
    – Sarien
    Dec 27, 2012 at 13:50
  • In your router you can define which channel to use. Some routers have auto-select. Regulations differ between countries; but usually channel 11 and below are permitted in all countries (some routers support additional/higher channels, which are not permitted in all countries). Please let us know whether this brought you at least closer to a solution, so I might sum it up to a useful answer.
    – Izzy
    Dec 27, 2012 at 14:06
  • It seems that the lower channels are not available for 5 GHz wireless. I set my phone to 2.4 GHz only and fixed channel seven on the access point but it didn't help.
    – Sarien
    Dec 27, 2012 at 16:46
  • 1
    Any hints in adb logcat?
    – ott--
    Dec 27, 2012 at 18:10

2 Answers 2


In the end I fixed it using the old "have you tried turning it off and on again?" on one of the APs. Make sure to try that first. ;)

So here is my little checklist, least annoying first:

(If you have other suggestions or things that worked for you let me know and I'll add them!)

  1. Recheck the password it is almost always the problem! (Hint to the Android devs: A more descriptive error for this case would be great. ;) )

  2. Reboot all devices. Yes, even if it works for other computers and if it will cut their network connection.

  3. Try adding the network manually and entering all the data manually.

  4. Try restricting all devices to specific channels and bands instead of using automatic discovery.

  5. If you use multiple devices make sure they don't interfere by setting them to different channels or selectively turning them off.

  6. Try using "adb logcat" to get more information.

  7. Try resetting your phone.


I have experienced this also with my phone (Galaxy Nexus). The main reason that I see causing this is a miss-typed password as i believe someone mentioned above. Another thing that has happened to me is a really low connection. Check to see how strong the wifi signal is in the spot where you are trying to connect. Sometimes if the connection is really weak it will keep the phone from connecting so try moving around your house also. I know this is pretty obvious but you said you had two networks so make sure your phone is not connected to the first one when you are trying connect to the second. If all of this does not solve the problem there is a workaround that I have found works most of the time: go to settings->wifi(make sure it is turned on so you can see all the available networks.). Click on the plus button at the bottom (right above the home button in the center). Enter your network's SSID (name that appears in the list of available networks) and select the security and password. Hit save and see if that works (you might have to than click on it in the list and hit connect but it should connect when you hit save.) Hope this helps!

  • I actually already tried manually adding the network earlier and it didn't help either. I also did indeed have at some point a wrong password set but I fixed and quadrupel checked that and it didn't help. Pretty sad though, that it's hard to tell when you just typed a wrong password.
    – Sarien
    Dec 28, 2012 at 1:19
  • Yeah it can be tough to see if you messed up the password sometimes. When you enter the SSID and password manually, there is a check box to "show password". That helps me.
    – ninge
    Dec 28, 2012 at 3:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .