8

I have a Moto Droid, running Android 2.2 (Froyo), although this behavior also existed on 2.1. Whenever I plug something in the headphone jack, the Music app will start up (sometimes with a bit of a delay) and start playing something (generally Christmas music). More often than not, I'm plugging in headphones to use Google Listen to listen to podcasts... if Listen is already running, I may end up with both apps playing at the same time.

The Music app doesn't seem to have any settings that would affect this behavior. Is there some way, short of deleting all of the music so that there's nothing to play?

4
  • I have almost the same problem; in my case, though, music doesn't start when I plug in the headphones, but rather, when I press the little button attached to them.
    – offby1
    Nov 1 '11 at 21:58
  • I upgraded to a new phone running Gingerbread about two months ago; haven't seen the problem since then, so it could be fixed.
    – TomG
    Nov 2 '11 at 2:00
  • Alas, I'm running Gingerbread.
    – offby1
    Nov 8 '11 at 5:41
  • Five years later, now on Lollipop - the same story with Google Play Music starting automatically when a bluetooth connection is made with my vehicle.
    – TomG
    Nov 2 '15 at 1:50
3

It's been reported as a known issue on code.google.com. There's a long list of 79 comments which seem to indicate that rooting and adding a program called "Autostarts" fixes the problem. This is obviously not something everyone is going to want to do... be careful if you go that route.

2
  • CyanogenMod has had this fixed since 5.0.8.
    – Broam
    Aug 18 '11 at 18:21
  • Thanks; I'd searched for the relevant bug before, and somehow not found that one.
    – offby1
    Nov 1 '11 at 21:58
2

You can use the Headset Blocker widget to disable that behavior.

1
  • It looks promising. I'll give it a try. Thanks.
    – TomG
    Sep 18 '10 at 11:15
1

Fixed! Go to: Settings; General Select: Context Awareness Select: When earphones are plugged in Then click the slide to disable. enter image description here

0

When you plug in your headset click the Music On The Go Event in smart connect and then go to the options and disable Smart Connect. Worked on my Sony Xperia Z3 on Droid 5.0.2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.