I tried using Flash Software, but it doesn't work for me.

I may have used the wrong version or my process is wrong.

Can anyone tell me the correct process?

  • Android Version : 2.3.4
  • Model Number : LT18i
  • Build Number : 4.0.2.A.0.62
  • You could start checking with our rooting index and see how it was done for the other Xperias. I will meanwhile add your question to that index, as this device (Arc S) was not yet listed there. Edit: Could you please edit your question and add some more details, e.g. the Android version you are currently running? That might be important for the answerer. – Izzy Apr 23 '13 at 9:26
up vote 1 down vote accepted

For most of Sony Ericsson Xperia devices, you can use Flashtool.

currently at version v0.9.10.1, last updated on 07/01/2013

There's a guide on how to use this software over at XDAs, that I've used to prepare the instructions that follows.


STEP 01 :: Requirements:

  • A computer running Windows, Linux or MAC;
  • The Sony Xperia device;
  • The appropriated cable to connect it to the computer.


STEP 02 :: Install Flashtool and perform all updates to it:

Refer to the installation instructions and software download on the Flashtool website, tab "installation".

Windows version:

  • Install the full install Flashtool 0.9.10.1 package
  • Apply the latest update (each update is cumulative)
  • Updates will not be functionnal if full 0.9.10.1 is not installed

Linux version:

  • Unpack the tar.7z package
  • Check that libusb-1.0 is installed. On 64bits system, both 64bit and 32bit should be installed.
  • Add these rules to /etc/udev:

    SUBSYSTEM=="usb", ACTION=="add", ATTRS{idVendor}=="0fce", ATTRS{idProduct}=="*", MODE="0777"
    
  • Apply the latest update (each update is cumulative)

  • Updates will not be functionnal if full 0.9.10.1 is not installed

Mac version:

  • Open the dmg package Copy the Flashtool App to Applications folder.
  • It will not run right from the dmg package
  • Apply the latest update (each update is cumulative)
  • Updates will not be functionnal if full 0.9.10.1 is not installed


STEP 03 :: Root your Sony Ericsson Xperia Arc S:

Refer to the tutorial at XDAs.

  • Start Flashtool

    Flashtool Interface

  • Connect the device to the computer and wait until it's recognized

  • Click the icon with the "Padlock [the second in a row]

  • Flashtool will start pushing files, wait till it finishes. Meanwhile the phone will reboot once.

  • When it's over Flashtool will notify "Root Access Allowed"

    Flashtool finish message

  • On your phone, open the application list and search for the app "Superuser".


For Troubleshooting, you can refer to common situations on the Flashtool website, tab "FAQ".

You can root the phone directly with no need for downgrading through this tool "Eroot":
download here

1- You need to have PC companion installed on your PC.

2- On your phone, Go to
settings > Security > Mark "Unknown sources"
Settings > Developer options > Mark USB debugging
Settings > Xperia > connectivity > USB connection mode > select MSC mode

3- After marking the settings above, connect your phone to PC ( Skip PC Companion installation on your phone ) and wait for the adb drivers to be installed.

You might need to disable your anti virus before this step.

4- Now, run the Eroot tool downloaded above -it's in Chinese i guess- you will see it's doing some downloading and then a Root button appears. Click on it.

and Baam, your phone is rooted. Look for the SuperUser app in ur apps pages. Also for further check you can use the Root Checker Basic app available on google play store.

If it somehow fails for the first time, give it another go. Restart everything, your PC, phones etc. If it doesn't work at all, you might need to try the other method for rooting i.e: downgrade-root-upgrade.

For the original post refer to: http://forum.xda-developers.com/showthread.php?t=2219711
Credits go to 'Nabeel' the author of this method.

btw I have tried this method on my Arc S (and Windows 7), and it did work :)

  • 3
    Please add all relevant information to your answer since the link may become unavailable and your answer in the current form doesn't provide a practical solution! – Zuul Jul 30 '13 at 14:00
  • sorry I am new to the site. Okay will do :) – Nour Jul 30 '13 at 14:06

Easiest way is unlock the bootloader and install a CWM or TWRP added kernel. Bootloader unlock wipe user data. Also rooting, unlocking bootloader voids the warranty.

  1. First unlock the bootloader, following this tutorial.
  2. Download and copy SuperSU zip file into your SD card.
  3. Next download Sony Xperia Arc S CWM/TWRP added kernel in here.
  4. Then install that kernel using flashtool, following this guide.
  5. When the phone booting continuously press and release the volume down key.
  6. In recovery go to "install zip from sdcard>Choose zip from sdcard" and install the SuperSU zip file.
  7. Select reboot system now.
  8. That's all.

https://www.youtube.com/watch?v=OxF4O5E2RiY I rooted easily following this video using eroot. (optional- Clockworkmode acess) Also, after rooting since i can't use bootloader i used CWM, so you can try from this video https:/ /www.youtube.com/watch?v=soHSsw3gZh0 , or in my case (since it didn't work) i installed (at the bottom of this first thread) http:/ /forum.xda-developers.com/showthread.php?t=1437840 CWM Installer-v5.apk . I gained access to CWM after rebooting and pressing back (or for some its volume down).

  • Welcome to Android Enthusiasts! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. Otherwise, your answer becomes useless in case the link dies. For further hints, please see: How do I write a good answer. – Izzy Oct 23 '14 at 16:10

use the one step root tool from eroot.net 1. download the eroot.exe file (11.1 mb) 2. connect your phone via usb after enabling usb debugging 3. click the green button on running the eroot tool

though it is in chinese but it is a single button and translates to root only i have used this tool to root more than just a few devices and it works everytime like a charm.

cheers

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.