6

I am using an android tablet at my work place. For some weird reason, WIFI has been disabled in the tablet. The only way to connect to the internet is via ethernet. At this point, I have a USB-Ethernet adapter. I am able to enable ethernet and connect. I even get an IP address assigned to my tablet.

But, the problem is, I am unable to access the internet on the tablet. When I try to open any application that requires connectivity to internet, I just get the error message "This application requires a working data connection".

Not sure if this is relevant, but I checked the file "sys/class/net/eth0" and it says "up".

Can someone help me out here?

Thank you ..

  • What apps have you tried? I can't believe all of them have the exact same error message. – Dan Hulme Jun 22 '13 at 9:58
  • 3
    "at my work place"? Most of the work-places I know have security measures to prevent "unknown devices" from connecting to the network (I wonder that you got an IP address assigned at all), so most likely all routing is blocked for your device. Have you talked to the company's IT stuff for that? They might need to put your tabbies MAC address into their "whitelist". – Izzy Jun 22 '13 at 11:26
  • Dan - Yes. All apps give me the same error message. – Vignesh P. Kannan Jun 22 '13 at 22:04
  • I would try to connect to a different network to rule out that it is the device. I think that Izzy is right, the router may be blocking you because your device is unknown to it. – John Jun 28 '13 at 6:45
  • If you are connecting to your work network I would suggest that it could be a network restriction on an "unrecognised" device. – user61926 May 31 '14 at 11:00
0

i had the same problem. EBay app told me the solution. My date and time were set manually in 2011. I set the good time and date automaticly and now my apps have access to internet.

0

If you can shell and run netcfg, there are a couple of other things you have to do. Namely set up DNS and a gateway:

To see network status:

netcfg

To bring up the ethernet connection, if it isn't already:

netcfg eth1 dhcp

Set up DNS, replacing the IP address as fit for your environment (this can be found via a Windows PC running on the same network with "ipconfig /all"):

setprop net.dns1 10.30.28.180

Set up the default gateway IP (which can also be found by running "ipconfig /all" on a Windows PC on the same network):

route add default gw 10.31.60.1 dev eth1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.