I have tried three methods for rooting my previous Android device, running 2.3.5 (Gingerbread). It's a Verizon Samsung Galaxy s (Fascinate - SCH-I500).

I have all the drivers installed for the device on my computer (Windows 8) and have USB Debug toggled. SuperOneClick failed to work after three attempts. Local rooting (No computer used) did not work either as that only rooted it about five seconds after boot, displaying a message on the home screen. The last method involved installing and app from the Play store and some software for my PC which I have forgot the name. I'm at a loss on how to root it so I can flash a custom ROM I have.

I had a general idea on where to start but as you've just read, all has failed. Side note: during all of these methods the SD Card was in phone but never mounted as per all the various instructions.

How can I root this reluctant device?

  • 1
    Did you take a look at our rooting index (linked from the 'rooting' tag)? It lists How do I root my Samsung Galaxy S?. Tried that method? (I might be wrong with this suggestion, as there are multiple variants of the Galaxy S around, but it's worth a look). – Izzy Jun 30 '13 at 21:43
  • I have tried that method. No luck – Chase Jul 1 '13 at 1:27
up vote 0 down vote accepted

As you describe your Samsung Fascinate is running Gingerbread, there's a rooting guide provided at TheUnlockr which you could try. It uses the tool to root the device, so you would need Odin Tool, Samsung Drivers, ClockworkMod Recovery, and Superuser for this.

Install the Samsung drivers first, then install ClockworkMod (which is where Odin is needed). Copy SuperUser to your SDCard, then boot into CWM (turn off the device, simultaneously hold Vol + + Vol - + Power). Select install zip from sdcard, then choose zip from sdcard. Chose the SuperUser file you've copied to your SDCard. Let it flash, and reboot using the reboot system now menu entry. Your device now should be rooted.

  • Looks like this worked? Then I should see to add it to the rooting index :) – Izzy Jul 1 '13 at 19:02

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.